Bug 448966 - Anaconda /etc/fstab should add comments for UUID entries
Anaconda /etc/fstab should add comments for UUID entries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Desktop, Documentation, FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 14:41 EDT by Bryan J Smith
Modified: 2014-09-14 20:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 14:57:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan J Smith 2008-05-29 14:41:31 EDT
Description of problem:

User unfamiliarity with new UUID entries in /etc/fstab.

FEATURE REQUEST

Consider having Anaconda add two (2) sets of comment lines in /etc/fstab:  
1.  Note meta '/dev/disk' in dev filesystem and relevant man page(s)
2.  Reference UUID (and creation date), LABEL and raw device at time of
install/upgrade

Version-Release number of selected component (if applicable):

Fedora 9 Anaconda.

How reproducible:

Use of UUID is by design, for safest possible filesystem mounts.


Steps to Reproduce:
1.  Install or upgrade to Fedora 9
2.
3.
  
Actual results:


Expected results:


Additional info:

Here's an example format (change or abbreviate as desired by maintainer) ...

#
# /etc/fstab
# Created by Anaconda Thu May 29 14:27:51 EDT 2008
#
# See '/dev/disk' for list of currently accessible filesystems
# See man (8) fstab (and/or others?) for more information
#
# Filesystems at time of Install/Upgrade:  
# UUID                                  Creation    Label     Mount
# 01234567-89ab-cdef-0123-456789abcdef  2008-05-28  /         /
# 340a1958-06eb-4f5d-b1ff-13607fa60ac8  2008-05-28  /usr      /usr
# ...
#
UUID=01234567-89ab-cdef-0123-456789abcdef    /        ext3    defaults   1 1
UUID=340a1958-06eb-4f5d-b1ff-13607fa60ac8    /usr     ext3    defaults   1 2
...
Comment 1 Bryan J Smith 2008-05-29 14:45:16 EDT
Forgot one, suggested field in comments:  Device

# ...
# Filesystems at time of Install/Upgrade:  
# UUID                                  Creation    Label     Mount     Device
# 01234567-89ab-cdef-0123-456789abcdef  2008-05-28  /         /         /dev/sda1
# 340a1958-06eb-4f5d-b1ff-13607fa60ac8  2008-05-28  /usr      /usr      /dev/sda2
# ...
Comment 2 Bryan J Smith 2008-05-30 10:26:24 EDT
This starting comment block may be better ...
# ...
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
# ...
Comment 3 Andy Lindeberg 2008-06-02 15:21:42 EDT
The reason UUIDs are used is because device names can change. If such a comment
were to be added, it wouldn't necessarily line up with reality and would be
uninformative.
Comment 4 Bryan J Smith 2008-06-02 15:32:15 EDT
To respond to your first statement, I agree.  That's why I wrote for ...  
  "How reproducible:
   Use of UUID is by design, for safest possible filesystem mounts."

To respond to your second statement, that's why I broke this down into two (2)
separate requests.
  "1.  Note meta '/dev/disk' in dev filesystem and relevant man page(s)
   2.  Reference UUID (and creation date), LABEL and raw device at time of"

So I will take your second statement to be that you do not necessarily agree to
doing #2.  I think we can still put a "date" on the comment, but if you fear it
will be obsolete info, we can drop it.

But I will _very_strongly_ recommend #1.  At least half of the long-time
end-users of Fedora I've talked to do _not_ even know the first thing on where
to go to look up this information.

Hence why my Comment #2 is:  

  This starting comment block may be better ...
  # ...
  # Accessible filesystems, by reference, are maintained under '/dev/disk'
  # See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
  # ...

We really need some sort of "basic info" in /etc/fstab.  If not for Fedora 9
soon, I'd strongly recommend it for Red Hat Enterprise Linux (RHEL) 6.
Comment 5 Chris Lumens 2008-06-03 14:57:17 EDT
Okay, the intro comment sounds reasonable to me.  Added.  Thanks for the suggestion.
Comment 6 Bryan J Smith 2008-06-03 15:11:10 EDT
Excellent.  Glad we came to an agreement.

After further review, I have to agree that information that could easily become
obsolete is probably not a good idea.  Besides, we want the users empowered to
understand, not merely look at dated info in /etc/fstab itself.  Furthermore, if
a user is really interested in what was setup at Install/Upgrade-time, they can
refer to the Anaconda logs.  I just realized that would be better, and not
something in /etc/fstab itself.

Thanx again!

Note You need to log in before you can comment on or make changes to this bug.