Bug 449020 - Anaconda does not detect existing installation for upgrade
Anaconda does not detect existing installation for upgrade
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 17:37 EDT by Daniel Ceregatti
Modified: 2008-06-02 15:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 15:19:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (36.16 KB, text/plain)
2008-05-29 17:37 EDT, Daniel Ceregatti
no flags Details

  None (edit)
Description Daniel Ceregatti 2008-05-29 17:37:30 EDT
I'm trying to upgrade from Fedora 8 to 9. I've tried the preupgrade program and
booting the dvd. Both offer me a first-time installation and no option to upgrade.

I've attached the anaconda.log of the attempt.

Here's some relevant info:

---------------------------------------------------------------------------

fdisk -l /dev/sda

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbcb80891

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         801     6426624   27  Unknown
Partition 1 does not end on cylinder boundary.
/dev/sda2             801        8450    61438976    7  HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3   *        8450       10999    20480000   af  Unknown
Partition 3 does not end on cylinder boundary.
/dev/sda4           11000       19457    67938885    5  Extended
Partition 4 does not end on cylinder boundary.
/dev/sda5           11000       11249     2008093+  82  Linux swap / Solaris
/dev/sda6           11250       19457    65930728+  83  Linux

---------------------------------------------------------------------------

df -h

/dev/sda6              61G   45G   14G  77% /
tmpfs                 991M   12K  991M   1% /dev/shm
/dev/sda2              59G   46G   14G  77% /dos

---------------------------------------------------------------------------

cat /etc/fstab

LABEL=/                 /                       ext3    defaults        1 1
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
LABEL=SWAP-sda5         swap                    swap    defaults        0 0
/dev/sda2               /dos                    ntfs-3g uid=500         0 0

---------------------------------------------------------------------------

tune2fs -l /dev/sda6 

tune2fs 1.40.4 (31-Dec-2007)
Filesystem volume name:   /
Last mounted on:          <not available>
Filesystem UUID:          d1b71135-54d8-4748-bfc5-7ba96dd05ce4
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal ext_attr resize_inode dir_index filetype
needs_recovery sparse_super large_file
Filesystem flags:         signed directory hash 
Default mount options:    user_xattr acl
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              16482816
Block count:              16482682
Reserved block count:     824134
Free blocks:              4342378
Free inodes:              16144296
First block:              0
Block size:               4096
Fragment size:            4096
Reserved GDT blocks:      1021
Blocks per group:         32760
Fragments per group:      32760
Inodes per group:         32704
Inode blocks per group:   1022
Filesystem created:       Fri Nov  9 00:52:37 2007
Last mount time:          Thu May 29 14:29:21 2008
Last write time:          Thu May 29 14:29:21 2008
Mount count:              139
Maximum mount count:      -1
Last checked:             Fri Nov  9 00:52:37 2007
Check interval:           0 (<none>)
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:		  128
Journal inode:            8
Default directory hash:   tea
Directory Hash Seed:      791c718b-7903-405c-969d-5531e7e62459
Journal backup:           inode blocks

Let me know if you need more info.

Daniel
Comment 1 Daniel Ceregatti 2008-05-29 17:37:30 EDT
Created attachment 307140 [details]
anaconda.log
Comment 2 Jeremy Katz 2008-05-29 17:53:22 EDT
Does it get found if you boot with 'linux upgradeany'?
Comment 3 Daniel Ceregatti 2008-05-29 18:13:25 EDT
Indeed, it does.
Comment 4 Daniel Ceregatti 2008-05-29 18:15:51 EDT
Additionally, it offers to upgrade the existing install of "Redhat 5
(/dev/sda6)". Where it gets the idea that I'm running "Redhat 5" I have no idea.
This machine started off with Fedora 8. It never had any other installation of
Linux.
Comment 5 Jeremy Katz 2008-06-01 17:21:09 EDT
That comes from reading the contents of /etc/redhat-release -- what does that
say on the system?
Comment 6 Daniel Ceregatti 2008-06-02 14:02:15 EDT
I've since performed the upgrade, so now it reads:

Fedora release 9 (Sulphur)

Since the machine only ever had Fedora 8 on it before, I presume it read
whatever Fedora 8 installed, but I have no way to confirm that now.
Comment 7 Andy Lindeberg 2008-06-02 15:19:38 EDT
Closing this because relevant information from F8 has been lost with the
upgrade. If anybody else experiences this problem, please reopen this or file a
new report.

Note You need to log in before you can comment on or make changes to this bug.