Bug 449074 - Segmentation fault when try downloading file from ftp server with IPv6 address [NEEDINFO]
Segmentation fault when try downloading file from ftp server with IPv6 address
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gftp (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Denise Dumas
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 05:35 EDT by Nicole Dai
Modified: 2014-06-02 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (ndai)


Attachments (Terms of Use)
Screenshot-gFTP 2.0.18 (56.86 KB, image/png)
2008-05-30 05:35 EDT, Nicole Dai
no flags Details

  None (edit)
Description Nicole Dai 2008-05-30 05:35:08 EDT
Description of problem:
gftp crashed when try downloading file from ftp server with IPv6 address. It
outputed Segmentation fault in terminal. I couldn't get more traceback because
it's not a c application which could not be debugged by gdb. bug-buddy and
debuginfo pkg also did not get any output. 

Version-Release number of selected component (if applicable):
RHEL5.2 Server GA
gftp-2.0.18-3.2.2

How reproducible:
Always

Steps to Reproduce:
1. Launch gftp by clicking Applications->Internet->gFTP or typing `gftp` in
terminal.
2. Configuration pls refer to the attachment.
3. Select the file you want to download and click left arrow button.
  
Actual results:
It crashed immediately.

Expected results:
The remote file is expected to be downloaded successfully.

Additional info:
Using firefox to download the same file on the same ftp server with IPv6 address
works fine.
Comment 1 Nicole Dai 2008-05-30 05:35:08 EDT
Created attachment 307179 [details]
Screenshot-gFTP 2.0.18
Comment 4 RHEL Product and Program Management 2008-07-21 19:01:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 RHEL Product and Program Management 2014-03-07 07:44:53 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 9 RHEL Product and Program Management 2014-06-02 09:08:21 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.