Bug 449185 - unusual messages on USB stick mount and unmount (including selinux denial)
unusual messages on USB stick mount and unmount (including selinux denial)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 19:11 EDT by Peter F. Patel-Schneider
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 19:25:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter F. Patel-Schneider 2008-05-30 19:11:15 EDT
Description of problem:

When I mount and unmount a USB stick I get lots of odd messages from automount,
plus an SELinux denial.  I don't believe that any of the automount messages are
useful.  I include the relevant portion of /usr/log/messages below.

Version-Release number of selected component (if applicable):

Fedora 9, completely up to date as of 30 May 2008

How reproducible:

Always

Steps to Reproduce:
1. Plug in USB stick, look in /var/log/messages
2. Unmount USB stick from desktop, look in /var/log/messages
3.
  
Actual results:

Lots of messages in /var/log/messages

Expected results:

Many fewer messages.

Additional info:


May 30 18:44:59 idefix kernel: usb 1-1: new high speed USB device using ehci_hcd
and address 3
May 30 18:44:59 idefix kernel: usb 1-1: configuration #1 chosen from 1 choice
May 30 18:44:59 idefix kernel: scsi7 : SCSI emulation for USB Mass Storage devices
May 30 18:44:59 idefix kernel: usb 1-1: New USB device found, idVendor=090c,
idProduct=1000
May 30 18:44:59 idefix kernel: usb 1-1: New USB device strings: Mfr=1,
Product=2, SerialNumber=3
May 30 18:44:59 idefix kernel: usb 1-1: Product: Flash Voyager
May 30 18:44:59 idefix kernel: usb 1-1: Manufacturer: Corsair
May 30 18:44:59 idefix kernel: usb 1-1: SerialNumber: A900000000025787
May 30 18:45:04 idefix kernel: scsi 7:0:0:0: Direct-Access     Corsair  Flash
Voyager    1100 PQ: 0 ANSI: 0 CCS
May 30 18:45:04 idefix kernel: sd 7:0:0:0: [sdb] 3932160 512-byte hardware
sectors (2013 MB)
May 30 18:45:04 idefix kernel: sd 7:0:0:0: [sdb] Write Protect is off
May 30 18:45:04 idefix kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
May 30 18:45:04 idefix kernel: sd 7:0:0:0: [sdb] 3932160 512-byte hardware
sectors (2013 MB)
May 30 18:45:04 idefix kernel: sd 7:0:0:0: [sdb] Write Protect is off
May 30 18:45:04 idefix kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write through
May 30 18:45:04 idefix kernel:  sdb: sdb1
May 30 18:45:04 idefix kernel: sd 7:0:0:0: [sdb] Attached SCSI removable disk
May 30 18:45:04 idefix kernel: sd 7:0:0:0: Attached scsi generic sg2 type 0
May 30 18:45:04 idefix hald: mounted /dev/sdb1 on behalf of uid 1316
May 30 18:45:04 idefix gnome-keyring-daemon[2651]: adding removable location:
volume_uuid_504B_1EBC at /media/OWLED
May 30 18:45:05 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash
May 30 18:45:05 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash-1316
May 30 18:45:05 idefix automount[2251]: lookup_mount: lookup(file): key ".Trash"
not found in map
May 30 18:45:05 idefix automount[2251]: lookup_mount: lookup(file): key
".Trash-1316" not found in map
May 30 18:45:05 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash
May 30 18:45:05 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:05 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash-1316
May 30 18:45:05 idefix automount[2251]: lookup_mount: lookup(file): key ".Trash"
not found in map
May 30 18:45:05 idefix automount[2251]: lookup_mount: lookup(file): key
".Trash-1316" not found in map

May 30 18:45:29 idefix hald: unmounted /dev/sdb1 from '/media/OWLED' on behalf
of uid 1316
May 30 18:45:29 idefix gnome-keyring-daemon[2651]: removing removable location:
volume_uuid_504B_1EBC
May 30 18:45:29 idefix setroubleshoot: SELinux prevented umount from mounting on
the file or directory "/media/.hal-mtab-lock" (type "mnt_t"). For complete
SELinux messages. run sealert -l 42707613-43bd-4794-b8eb-5643e9460f0f
May 30 18:45:30 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash
May 30 18:45:30 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash-1316
May 30 18:45:30 idefix automount[2251]: lookup_mount: lookup(file): key ".Trash"
not found in map
May 30 18:45:30 idefix automount[2251]: lookup_mount: lookup(file): key
".Trash-1316" not found in map
May 30 18:45:30 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash
May 30 18:45:30 idefix automount[2251]: create_udp_client:99: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: create_tcp_client:308: hostname lookup
failed: No such process
May 30 18:45:30 idefix automount[2251]: lookup_mount: exports lookup failed for
.Trash-1316
May 30 18:45:30 idefix automount[2251]: lookup_mount: lookup(file): key ".Trash"
not found in map
May 30 18:45:30 idefix automount[2251]: lookup_mount: lookup(file): key
".Trash-1316" not found in map
Comment 1 John R. Deal Jr. 2008-09-02 06:25:21 EDT
I also had this problem with a Corsair USB flash drive with F9 and F10A+.  The same drive works on FC6.  Seems to be fixed with: Linux localhost.localdomain 2.6.27-0.290.rc5.fc10.i686 #1 SMP Thu Aug 28 21:44:53 EDT 2008 i686 i686 i386 GNU/Linux. Test hardware is IBM NetVista desktop.
Comment 2 Eric Paris 2008-11-04 17:12:06 EST
If this is still a problem can you include the output of the sealert command as indicated in the /var/log/messages file when you have this trouble?
Comment 3 Peter F. Patel-Schneider 2008-11-06 22:05:04 EST
I think that the problem is resolved - at least I haven't seen it for a while.
Comment 4 Peter F. Patel-Schneider 2009-04-29 19:25:37 EDT
I'm going to try to close this bug, as it doesn't appear to be currently happening.  I expect that some change in F10 or F11 has fixed it.

Note You need to log in before you can comment on or make changes to this bug.