Bug 449249 - Eclipse's internal browser crashes on KDE
Eclipse's internal browser crashes on KDE
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-31 18:06 EDT by pfpenteado
Modified: 2008-06-11 18:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 18:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description pfpenteado 2008-05-31 18:06:07 EDT
Description of problem:
When trying to use Eclipse's internal browser to view the documentation, it
crashes Eclipse if I am using KDE. On Gnome, on the same system, there seems to
be no problem. This happens with any of the 3 independent installations of
Eclipse I have: Fedora Eclipse (x86_64) from Fedora 9 with all the current
updates, Photran (x86_64) and IDL (i386). It all worked fine on Fedora 8.


Version-Release number of selected component (if applicable):
eclipse-jdt-3.3.2-11.fc9.x86_64


How reproducible:
Every time


Steps to Reproduce:
1. Start Eclipse on KDE
2. Open the help on the internal browser
3. Shift focus to the internal browser
  
Actual results:
Eclipse crashes the moment the focus moves to the internal browser.

Additional info:
The error message given after the crash:

JVM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx512m
-XX:MaxPermSize=128m
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.3.R33x_v20080118/eclipse_1023.so
-startup /usr/share/eclipse/startup.jar
-exitdata 22000b
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=128m
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
Comment 1 Andrew Overholt 2008-06-02 09:48:33 EDT
I have no KDE machine on which to test this.  I'll see if I can find time to set
up a VM.

In the meantime, can you try with an upstream (download.eclipse.org) build?  I
suspect it won't show any internal browser stuff but I'm interested what the
results are there.  Try a 3.4 release candidate if possible (3.4 RC3 is out now).

Thanks.
Comment 2 pfpenteado 2008-06-11 18:38:31 EDT
I did not have a chance to try the new Eclipse. But after this week's updates
from the Fedora Updates repository, the problem is now gone. I do not know which
packages specifically fixed it, I just noticed that there were among them
updates to GTK and KDE, but not to Eclipse.

Note You need to log in before you can comment on or make changes to this bug.