Bug 449257 - Biomech Supply Base Rear Exit: remove a barrier or change coordinates.
Biomech Supply Base Rear Exit: remove a barrier or change coordinates.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: blobAndConquer (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 01:35 EDT by Chris Schembari
Modified: 2008-06-01 04:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-01 04:34:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of blobAndConquer. (63.38 KB, image/jpeg)
2008-06-01 01:35 EDT, Chris Schembari
no flags Details

  None (edit)
Description Chris Schembari 2008-06-01 01:35:40 EDT
Description of problem:
  In a game level titled "Biomech Supply Base Rear Exit" (also known 
internally as 'Boss Battle 2'), Bob and Teeka must battle three very tough 
BioTanks along with a horde of assorted enemy Blobs. At the beginning of this 
level, Bob must pick up a crate of C4 and blast a hole in the wall in front of 
him (to get to the battle area), while behind him is an invisible barrier that 
keeps Bob and Teeka from going anywhere else but forward. In game version 
0.91, this barrier was unimportant because Bob and Teeka always got deposited 
on the correct side of it, the side with the C4 and the "blowable" wall. For 
version 0.93, however, some changes were made by the game designers so that 
Bob and Teeka both almost always land on the other side, in an open grassy 
courtyard where that same barrier then keeps both Blobs from continuing on 
with the rest of the game. The C4 and the weak wall can't be reached. This did 
not happen at all in 0.91 but in 0.93 it happens repeatedly, both when Our 
Heroes initially arrive in this level, when I load that level from the Load 
Game menu screen, and when enemies kill Bob and I click Retry or Load Game 
from the resulting "Mission failed" screen. Curiously, the only time that Bob 
lands in the right spot is when I load this level by any of the above methods, 
see Bob and Teeka on the wrong side as above, then immediately hit Escape and 
click on the Restart level button. Only then do Bob and Teeka land in the 
right spot, allowing me to grab the C4 and play the level normally.

  I recommend that this invisible barrier be removed from the game, allowing 
free passage between the grassy courtyard and the tank battle area.

Version-Release number of selected component (if applicable): 0.93

How reproducible: Every time.

Steps to Reproduce: See above description.
Comment 1 Chris Schembari 2008-06-01 01:35:40 EDT
Created attachment 307300 [details]
Screenshot of blobAndConquer.
Comment 2 Chris Schembari 2008-06-01 01:38:47 EDT
Re: "change coordinates" in the title
  I was going to alternately suggest that Bob and Teeka's arrival coordinates 
be changed to ones on the other side of the barrier, if for some reason it was 
deliberately left in this game version.
Comment 3 Hans de Goede 2008-06-01 03:39:50 EDT
Thanks for reporting this, I've forwarded your issue upstream, lets wait and see
what they have to say.
Comment 4 Hans de Goede 2008-06-01 04:34:21 EDT
Here's upstreams reaction:

"This has been fixed and will be in the next release."

To which I asked:

"any chance you could tell me what changes are needed to fix this in 0.93?"

To which the answer was:

"To fix the bug in the current version you'd need to fiddle with both some of
the data files, as well as GTK Radiant.... It's probably just worth waiting
for the next release."

So thats what I'll do.

Note You need to log in before you can comment on or make changes to this bug.