Bug 449535 - YM status cannot include URL
YM status cannot include URL
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 16:26 EDT by manuel wolfshant
Modified: 2008-06-05 21:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 17:57:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description manuel wolfshant 2008-06-02 16:26:54 EDT
Description of problem:
For a release or two, pidgin does not allow to use URL links as status for Yahoo
messenger. There seems to be a bug when processing the last dot in the domain
name. For instance
http://www --> displayed
http://www.220 -> displayed
http://www.220.ro --> not displayed, the previous value is retained


Version-Release number of selected component (if applicable):
pidgin-2.4.2-1.fc7
also appears in http://rpm.pidgin.im/rhel/5/i386/pidgin-2.4.2-0.el5.i386.rpm

How reproducible:
always

Steps to Reproduce:
1. set as status any text but not an URL; see the status change as it should
2. set as status an URL; watch the status NOT change if the final dot in the
domain name is included

  
Actual results:
If the new YM status includes an URL, pidgin broadcasts either the previous
status or nothing at all.
Comment 1 manuel wolfshant 2008-06-02 16:30:59 EDT
Additional comments: the status as written in ~/.purple/accounts.xml is correct.
The value which is broadcast is not.
Comment 2 manuel wolfshant 2008-06-05 17:57:13 EDT
further research shows that this behavior is due to yahoo servers filtering
based om some unknown-unsane-idiotic regexes. sorry for the noise.
Comment 3 Stu Tomlinson 2008-06-05 21:38:40 EDT
(In reply to comment #2)
> further research shows that this behavior is due to yahoo servers filtering
> based om some unknown-unsane-idiotic regexes. sorry for the noise.

Thanks for figuring this much out, do you have any references to the problem?
Does it also affect the official client? I'd like to close upstream bug
http://developer.pidgin.im/ticket/5864 too :)

Note You need to log in before you can comment on or make changes to this bug.