Bug 449643 - Unhandled exception report will not save to floppy
Unhandled exception report will not save to floppy
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
http://meandering-pen.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 18:11 EDT by Gary Fazenbaker
Modified: 2008-06-21 20:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 16:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Fazenbaker 2008-06-02 18:11:09 EDT
Description of problem: DVD ordered from linux-CD. Installing on and older 
machine that had been running Fedora 6 and was stable for a long while.
The install gets past the point "Preparing Transaction from Install Source"
Actually begins installing packages. Then gets an "unhandled exception error" 
with a comment that it is propably a bug. At this point the network is 
available but presumably not all of the hardware (i.e. floppy) because the save 
locally radio button does not work. For some reason the upload to server 
feature is not accepting my credentials for ftp to my server. The message is 
cryptic "failed". I will continue to search Docs for an answer but if you have 
any pointers to the information I need to enter in the save dump form I would 
appreciate hearing from you.

Gary
faz67@yahoo.com
http://meandering-pen.com
  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2008-06-03 11:05:21 EDT
Can you cancel saving the exception, put a floppy disk into the drive, and click
"save" again?  It looks like we're only detecting removable devices if they
already have media present when the save dialog is shown.
Comment 2 Gary Fazenbaker 2008-06-03 16:14:33 EDT
Thank you Chris
That makes perfect sense and I will certainly try it.
I have tried the install several more times and it 
doesn't seem to die in the same place every time.
The message does say it is probably a bug.
And to blame it on anaconda.
Thanks Again
Gary 
Comment 3 Chris Lumens 2008-06-03 17:38:15 EDT
Also - the save to remote uses scp.  I know it's not clear, but it'll be much
more obvious in the next release of Fedora.
Comment 4 Gary Fazenbaker 2008-06-03 19:23:46 EDT
OMG another network protocol "scp"??????
I was almost ready to take the training 
wheels of of SSL!
Comment 5 Gary Fazenbaker 2008-06-04 02:22:56 EDT
Chris
No luck putting in the floppy and restarting the capture, still unavailable.

I copied these messages which seemed the most relevent.

The first is just a warning.

1:34 Warning:/usr/lib/python2.5/site packages/yum/repos/yum progress.  >>>>>
progressbar called when popped self.callback.progressbar (num, len(repos), >>>
repo.id)

In the second something actually failed!
 
1:35 WARNING:/user/lib/anaconda/gui.py 563:gtk WARNING;gtk_progress-set: >>>>>
percentage:assertion'percentage>=0&&percentage<=1.0'failed self.progress. >>>>>
set_fraction(newval)

Looking through I saw it mount the CD but not the floppy.
Kind of hard to be sure in that small box.


HTH
Gary 
Comment 6 Gary Fazenbaker 2008-06-04 19:48:24 EDT
(In reply to comment #1)
> Can you cancel saving the exception, put a floppy disk into the drive, and 
click
> "save" again?  It looks like we're only detecting removable devices if they
> already have media present when the save dialog is shown.

Chris
No luck putting in the floppy and restarting the capture, still unavailable.

I copied these messages which seemed the most relevent.

The first is just a warning.

1:34 Warning:/usr/lib/python2.5/site packages/yum/repos/yum progress.  >>>>>
progressbar called when popped self.callback.progressbar (num, len(repos), >>>
repo.id)

In the second something actually failed!
 
1:35 WARNING:/user/lib/anaconda/gui.py 563:gtk WARNING;gtk_progress-set: >>>>>
percentage:assertion'percentage>=0&&percentage<=1.0'failed self.progress. >>>>>
set_fraction(newval)

Looking through I saw it mount the CD but not the floppy.
Kind of hard to be sure in that small box.


HTH
Gary 
Comment 7 Gary Fazenbaker 2008-06-04 19:49:32 EDT
(In reply to comment #1)
> Can you cancel saving the exception, put a floppy disk into the drive, and 
click
> "save" again?  It looks like we're only detecting removable devices if they
> already have media present when the save dialog is shown.

Chris
No luck putting in the floppy and restarting the capture, still unavailable.

I copied these messages which seemed the most relevent.

The first is just a warning.

1:34 Warning:/usr/lib/python2.5/site packages/yum/repos/yum progress.  >>>>>
progressbar called when popped self.callback.progressbar (num, len(repos), >>>
repo.id)

In the second something actually failed!
 
1:35 WARNING:/user/lib/anaconda/gui.py 563:gtk WARNING;gtk_progress-set: >>>>>
percentage:assertion'percentage>=0&&percentage<=1.0'failed self.progress. >>>>>
set_fraction(newval)

Looking through I saw it mount the CD but not the floppy.
Kind of hard to be sure in that small box.


HTH
Gary 
Comment 8 Gary Fazenbaker 2008-06-21 20:18:22 EDT
found a solution for this one it's called UBUNTU!
BYE

Note You need to log in before you can comment on or make changes to this bug.