Bug 449662 - nm-system-settings doesn't work - policykit issues?
nm-system-settings doesn't work - policykit issues?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 18:28 EDT by Orion Poplawski
Modified: 2008-07-09 17:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.7.0-0.6.9.svn3675.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 17:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-06-02 18:28:05 EDT
Description of problem:

Jun  2 16:09:37 cynosure hal-acl-tool: libpolkit: skipping unknown tag <vendor>
at line 8 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:37 cynosure hal-acl-tool: libpolkit: skipping unknown tag
<vendor_url> at line 9 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:37 cynosure hal-acl-tool: libpolkit: skipping unknown tag
<icon_name> at line 10 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:37 cynosure hal-acl-tool: libpolkit: skipping unknown tag <vendor>
at line 8 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:37 cynosure hal-acl-tool: libpolkit: skipping unknown tag
<vendor_url> at line 9 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:37 cynosure hal-acl-tool: libpolkit: skipping unknown tag
<icon_name> at line 10 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:40 cynosure NetworkManager: <info>  Trying to start the system
settings daemon...
Jun  2 16:09:40 cynosure nm-system-settings: polkit_error_get_error_message:
assertion `error != NULL' failed
Jun  2 16:09:40 cynosure nm-system-settings: Cannot initialize libpolkit: (null)
Jun  2 16:09:40 cynosure nm-system-settings: polkit_error_free: assertion `error
!= NULL' failed
Jun  2 16:09:40 cynosure pulseaudio: libpolkit: skipping unknown tag <vendor> at
line 8 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:40 cynosure pulseaudio: libpolkit: skipping unknown tag
<vendor_url> at line 9 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:09:40 cynosure pulseaudio: libpolkit: skipping unknown tag <icon_name>
at line 10 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:10:03 cynosure gconfd (orion-3022): None of the resolved addresses are
writable; saving configuration settings will not be possible
Jun  2 16:10:11 cynosure hald[2408]: libpolkit: skipping unknown tag <vendor> at
line 8 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:10:11 cynosure hald[2408]: libpolkit: skipping unknown tag
<vendor_url> at line 9 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy
Jun  2 16:10:11 cynosure hald[2408]: libpolkit: skipping unknown tag <icon_name>
at line 10 of
/usr/share/PolicyKit/policy/org.freedesktop.network-manager-settings.system.policy

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.6.8.svn3669.fc8
Comment 1 Orion Poplawski 2008-06-02 18:45:25 EDT
If I remove the vendor, vendor_url, and icon_name tags, those messages go away,
but the other errors remains and nm-system-settings fails.
Comment 2 Dan Williams 2008-06-03 12:01:57 EDT
Hmm, it worked for me on my F8 box, will test again.
Comment 3 Orion Poplawski 2008-06-05 13:35:23 EDT
Still present with NetworkManager-0.7.0-0.6.8.svn3675.fc8
Comment 4 Dan Williams 2008-06-05 13:44:54 EDT
I'm not seeing these on my F8 box with latest updates.  Are you running in
SELinux enforcing mode?  If so, I'll try that.
Comment 5 Orion Poplawski 2008-06-05 13:52:37 EDT
enforcing and with updates-testing enabled and up-to-date.
Comment 6 Dan Williams 2008-06-05 21:28:36 EDT
Dan: how do I execute nm-system-settings with the right context?  I can't reproduce the issue if I just 
run it as root, I need to run it in the same context as dbus-launch executes it in.  It segfaults when 
enforcing mode is turned on and that's definitely a bug in nm-system-settings.  I can't seem to get a 
corefile out of it, so I guess I need to be able to gdb it under the right context?
Comment 7 Dan Williams 2008-06-06 15:36:37 EDT
Will be fixed in 0.7.0-0.6.9.svn3675.fc8 and already upstream in SVN
Comment 8 Fedora Update System 2008-06-06 16:16:12 EDT
NetworkManager-0.7.0-0.6.9.svn3675.fc8 has been submitted as an update for Fedora 8
Comment 9 Fedora Update System 2008-06-11 00:37:02 EDT
 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update '.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5203
Comment 10 Orion Poplawski 2008-06-25 14:11:29 EDT
I'm actually using NetworkManager-0.7.0-0.7.svn3747.fc8 locally and that works
for me.  I'm going to assume this earlier one works too.
Comment 11 Fedora Update System 2008-07-09 17:46:56 EDT
NetworkManager-0.7.0-0.6.9.svn3675.fc8, NetworkManager-openvpn-0.7.0-10.svn3632.fc8, NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.