Bug 449708 - No Groups Available in any repository
No Groups Available in any repository
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-utils (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 22:00 EDT by John T. Rose
Modified: 2013-03-14 15:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 15:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John T. Rose 2008-06-02 22:00:13 EDT
Description of problem:

Since the release of RHEL5.2 repoquery doesn't seem to be able to find any groups.

Version-Release number of selected component (if applicable):

yum-utils-1.1.10-9.el5

How reproducible:

Seems to occur on every 5.2 system I have.

Steps to Reproduce:
1. repoquery -ag
2. digest python traceback
  
Actual results:

Traceback (most recent call last):
  File "/usr/bin/repoquery", line 809, in ?
    main(sys.argv)
  File "/usr/bin/repoquery", line 795, in main
    repoq.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 470, in doGroupSetup
    return self._getGroups()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 526, in _getGroups
    raise Errors.GroupsError, 'No Groups Available in any repository'
yum.Errors.GroupsError: No Groups Available in any repository

Expected results:

A list of groups.

Additional info:
Comment 1 James Antill 2013-03-14 15:58:04 EDT
 I believe this got fixed in a RHEL-5 update.

Note You need to log in before you can comment on or make changes to this bug.