Bug 449752 - gnome-scan crashes on startup
gnome-scan crashes on startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-scan (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 08:01 EDT by James Begley
Modified: 2008-06-03 14:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 14:33:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
running flegita from gdb (2.88 KB, application/octet-stream)
2008-06-03 11:48 EDT, James Begley
no flags Details
GDB running as root (3.76 KB, application/octet-stream)
2008-06-03 11:52 EDT, James Begley
no flags Details

  None (edit)
Description James Begley 2008-06-03 08:01:20 EDT
Description of problem:
flegita (gnome-scan) core dumps on start up.

Version-Release number of selected component (if applicable):
[james@jumbovaio]$ rpm -qa | grep gnome-scan
gnome-scan-0.6-2.fc9.i386
gnome-scan-libs-0.6-2.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Start flegita
  
Actual results:
[james@jumbovaio]$ flegita
** (flegita:6643): DEBUG: Initializing gnome-scan 0.6 for flegita (flegita)
** (flegita:6643): DEBUG: gsane-module.c:39: SANE version is 1.0.19
03a58d7f-6663-d6f2-0a2f8cd6-0287443d is dumped
[james@jumbovaio]$ 

Expected results:
flegita starts and runs properly

Additional info:
Better progress is wmade when running flegita as root - the UI opens and is 
useable until the first scan is completed, at which point I get a segfault.

It appears that flegita is attempting to log a kernel module that the ordinary 
user doesnt have permission to do
Comment 1 Deji Akingunola 2008-06-03 11:05:16 EDT
I've not seen such crash on x86_64 F-9, as a normal user. Can you please run
flegita under gdb, collect the backtrace and post the result?
(To run flegita under gdb, run gdb on the commandline line; at the gdb prompt,
type 'file /usr/bin/flegita'; then type 'run'. And if you are able to reproduce
the crash while running under gdb, type 'bt' to generate the backtrace.
Thank you.
Comment 2 James Begley 2008-06-03 11:48:43 EDT
Created attachment 308256 [details]
running flegita from gdb

Results from running flegita under GDB - I've installed the debuginfo rpm for
gnome-scan, but I guess that this will could be more useful if I install more
debuginfo rpms.

The interesting lines (well, to me at any rate) are

FATAL: Error inserting parport
(/lib/modules/2.6.25.4-30.fc9.i686/kernel/drivers/parport/parport.ko):
Operation not permitted
FATAL: Error inserting parport_pc
(/lib/modules/2.6.25.4-30.fc9.i686/kernel/drivers/parport/parport_pc.ko):
Operation not permitted
FATAL: Error inserting lp
(/lib/modules/2.6.25.4-30.fc9.i686/kernel/drivers/char/lp.ko): Operation not
permitted

suggesting that for some reason these kernel modules aren't loaded correctly.
Comment 3 James Begley 2008-06-03 11:52:21 EDT
Created attachment 308259 [details]
GDB running as root

Same proceedure, this time running as root.
Comment 4 Deji Akingunola 2008-06-03 12:19:19 EDT
From where did you get /usr/lib/libmfp.so? What scanner in particular are you
trying to use with flegita when it crashed, and have you installed any closed
source scanner driver?
Comment 5 James Begley 2008-06-03 13:53:36 EDT
Ah, yes.  Should have thought of that.  The scanner is a Samsung SCX-4200, 
which comes with its own closed source drivers, which seem to be causing the 
problems.

Using the information on the web (particularly the instructions at http://
ubuntu-utah.ubuntuforums.org/showthread.php?t=245545 and http://
jacobo.tarrio.org/Samsung_SCX-4200_on_Debian ) I have worked around these 
problems and got things working OK.

Sorry for the noise, this bug can be closed as far as I'm concerned.
Comment 6 Deji Akingunola 2008-06-03 14:33:02 EDT
(In reply to comment #5)
> Ah, yes.  Should have thought of that.  The scanner is a Samsung SCX-4200, 
> which comes with its own closed source drivers, which seem to be causing the 
> problems.
> 
...
> 
> Sorry for the noise, this bug can be closed as far as I'm concerned.

OK. Actually you could have close the bug yourself, since you're the reporter.
I'm closing it now.

Note You need to log in before you can comment on or make changes to this bug.