Bug 449814 - API for system.deleteSystems() is wrong
API for system.deleteSystems() is wrong
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn505
All Linux
low Severity low
: ---
: ---
Assigned To: Sebastian Skracic
Amy Owens
us=28718
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 14:45 EDT by Stephen Herr
Modified: 2008-06-06 10:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 10:22:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHN API method caller (2.00 KB, application/x-perl)
2008-06-03 14:45 EDT, Stephen Herr
no flags Details

  None (edit)
Description Stephen Herr 2008-06-03 14:45:10 EDT
Description of problem:
The deleteSystems method description is "Delete systems given a list of system
ids." However, the method can only handle a single system ID at a time. Either
the description (and name?) or the functionality need to change. 

Version-Release number of selected component (if applicable):
5.0.5

How reproducible:
Always

Steps to Reproduce:
1. Run attached script
2. Note: systemid1 and systemid2 should be the ids of systems you don't mind
deleting.
  
Actual results:
Fault returned from XML RPC Server, fault code -1: Could not find method
deleteSystems in class class com.redhat.rhn.frontend.xmlrpc.system.SystemHandler

Expected results:
script returns and system profiles are deleted

Additional info:
It currently works fine if you only give it one system id at a time. However the
description says that you should be able to give it a list of indeterminate length.
Comment 1 Stephen Herr 2008-06-03 14:45:10 EDT
Created attachment 308277 [details]
RHN API method caller
Comment 2 Sebastian Skracic 2008-06-06 10:22:57 EDT
Nope, not a bug.  The API expects list as the last argument, therefore Perl
client code has to be adjusted like this:

# arbitrary long list of system IDs
my @systemidlist = (1011536347,  1011834030);
my $result = $client->call('system.delete_systems', $session, \@systemidlist);
...

Note You need to log in before you can comment on or make changes to this bug.