Bug 449866 - ls -ZC Segmentation fault
ls -ZC Segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 20:20 EDT by Joe Nall
Modified: 2008-06-11 00:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 6.10-25.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 00:39:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Nall 2008-06-03 20:20:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_3; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.20

Description of problem:
ls -ZC on an MLS/Permissive system dies with a segmentation fault. The same command on a F8 Targeted/Enforcing system does not.

Version-Release number of selected component (if applicable):
coreutils-6.10-23.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
ls -ZC

Actual Results:
segmentation fault

Expected Results:
listing

Additional info:
Comment 1 Ondrej Vasik 2008-06-04 11:18:34 EDT
Thanks for report, will be fixed in next coreutils builds. Problem caused by
reworking redhat selinux patch because of coreutils-6.10 release.
Comment 2 Ondrej Vasik 2008-06-04 15:45:44 EDT
Rawhide fix built as coreutils-6.12-2.fc10
(http://koji.fedoraproject.org/koji/taskinfo?taskID=645805) , feel free to check
it before the fix will go to F9.
Comment 3 Fedora Update System 2008-06-10 08:11:16 EDT
coreutils-6.10-25.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-11 00:39:56 EDT
coreutils-6.10-25.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.