Bug 449919 - General: Uptime SNMP
General: Uptime SNMP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Lestach
wes hayutin
:
Depends On:
Blocks: 463877
  Show dependency treegraph
 
Reported: 2008-06-04 05:44 EDT by Nick Strugnell
Modified: 2009-09-10 14:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2008-06-04 05:44:08 EDT
Description of problem:
The General: Uptime SNMP probe is supposed to report the uptime of the queried
machine. However it just reports the uptime of snmpd stack, so gives misleading
reports if the snmp stack is cycled on the target.

Version-Release number of selected component (if applicable):
perl-NOCpulse-Probe-1.183.1-18.rhel4

How reproducible:
always

Steps to Reproduce:
1.Configure a General: Uptime SNMP probe
2.
3.
  
Actual results:
Returns the uptime of the SNMP stack on the target

Expected results:
Returns the uptime of the target host

Additional info:
The problem is that the probe queries DISMAN-EVENT-MIB::sysUpTimeInstance /
172.18.204.11 1.3.6.1.2.1.1.3.0

It should instead query HOST-RESOURCES-MIB::hrSystemUptime.0 / 172.18.204.11
1.3.6.1.2.1.25.1.1.0
Comment 1 Miroslav Suchý 2009-01-12 08:09:13 EST
Notes to myself:
we will need to edit
./monitoring/NOCpulsePlugins/General/UptimeSNMP.pm
and HOST-RESOURCES-MIB::hrSystemUptime.0 returns string ("212 hours 35 minutes 19 seconds" ) whereas sysUpTimeInstance returns timeticks - is is compatimble or wee need to do converse? Investigate...
Comment 2 Tomas Lestach 2009-04-16 08:07:16 EDT
Probe changed to query hrSystemUptime according to Description.
Conversion not needed, because both queries return values in Timeticks.

Commit: 2830947c7292c66bc84a2eddb02b616ee5ad3b82
Tag: NOCpulsePlugins-2.208.6-1
Comment 3 Tomas Lestach 2009-05-05 10:10:36 EDT
Available in composes since Satellite-5.3.0-RHELx-re20090501.1
Comment 4 wes hayutin 2009-05-19 12:17:14 EDT
[root@rlx-2-20 .ssh]# uptime
 16:11:49 up 8 days,  2:32,  1 user,  load average: 0.00, 0.00, 0.00
[root@rlx-2-20 .ssh]# 


Probe:  	General: Uptime SNMP
Monitoring Scout 	RHN Monitoring Satellite
Status: 	OK, Uptime 8 days, 02:30:55.37
Last update: 	5/19/09 12:09:30 PM EDT


looks good
verified
Comment 5 Jan Pazdziora 2009-09-07 04:58:52 EDT
Stage validated with Satellite-5.3.0-RHEL5-re20090820.1:

[root@vmware139 ~]# uptime
 10:43:01 up 17 days, 17:43,  2 users,  load average: 0.08, 0.36, 0.43

General: Uptime SNMP   	 Uptime 17 days, 17:42:35.02 

even if I've just hour ago installed snmpd.

Moving to RELEASE_PENDING.
Comment 6 Brandon Perkins 2009-09-10 14:48:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.