Bug 449931 - Package ocaml-ocamldoc missing Provides
Package ocaml-ocamldoc missing Provides
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ocaml (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 06:45 EDT by Peter Lemenkov
Modified: 2008-06-04 19:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 19:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lemenkov 2008-06-04 06:45:02 EDT
When I needed to install ocamldoc I tried yum install ocamldoc first, but failed
because this program packaged as ocaml-ocamldoc.

Simple addition of Provides: ocamldoc to proper section in ocaml.spec should
solve this issue.
Comment 1 Richard W.M. Jones 2008-06-04 06:51:53 EDT
Yeah, I kind of agree with you in this case.

There were some very bogus provides ('lablgl', 'lablgtk') which I finally removed from
Rawhide a couple of weeks ago.  Those are libraries and the packaging policy clearly
states that the OCaml libraries are 'ocaml-foo{,-devel}'.

But for programs like ocamldoc I guess it's OK to have an extra 'Provides: ocamldoc'.

Of course, yum search ocamldoc would have worked :-)

I'll rebuild in Rawhide in a moment ...
Comment 2 Richard W.M. Jones 2008-06-04 19:28:26 EDT
Done.

Note You need to log in before you can comment on or make changes to this bug.