Bug 449983 - [RHEL5.2] Confusing quick add contact
Summary: [RHEL5.2] Confusing quick add contact
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Milan Crha
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-04 15:51 UTC by Petr Šplíchal
Modified: 2016-06-01 01:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 09:16:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 448441 0 None None None Never
Red Hat Product Errata RHBA-2009:1260 0 normal SHIPPED_LIVE evolution bug fix update 2009-09-01 13:26:12 UTC

Description Petr Šplíchal 2008-06-04 15:51:20 UTC
Description of problem:

When using right click on an email header (e.g. sender) to quickly add a contact
to address book the "select address field" is set to nothing by default which
(without changing it) after quickly pressing ok button (which is expected here
as this is "quick add" feature) results in: nothing happens. Very confusing (at
first sight it looks like it does not work at all). No error, no alert, no
contact added. The same happens when "Edit full" is pressed.

Version-Release number of selected component (if applicable):
evolution-2.12.3-8.el5_2.2

How reproducible:
Always

Steps to Reproduce:
1. right click on sender email address
2. choose "Add to address book"
3. press OK or Edit full button
  
Actual results:
Select address book field is empty.
OK button is clickable.
After clicking OK no contact added.

Expected results:
Default address book is set by default.
OK button should be disabled when there is no address book selected.

Comment 2 RHEL Program Management 2008-07-21 23:01:13 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 5 Milan Crha 2009-02-10 13:21:39 UTC
Corresponding upstream bug for this, with a patch:
http://bugzilla.gnome.org/show_bug.cgi?id=448441

Comment 10 zhanghaiyan 2009-06-09 06:52:27 UTC
The bug can not be reproduced on RHEL5.4 with below packages:
evolution-2.12.3-18.el5
evolution-data-server-1.12.3-17.el5
evolution-connector-2.12.3-10.el5

Comment 12 errata-xmlrpc 2009-09-02 09:16:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1260.html


Note You need to log in before you can comment on or make changes to this bug.