Bug 449987 - Gdm crash if a user's home directory resides on an unknown filesystem type
Gdm crash if a user's home directory resides on an unknown filesystem type
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 12:26 EDT by Danny Baumann
Modified: 2015-01-14 18:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 18:30:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix segfault by assuming a non-local filesystem for unknown filesystems (in doubt, take the safe choice) (767 bytes, patch)
2008-06-04 12:26 EDT, Danny Baumann
no flags Details | Diff

  None (edit)
Description Danny Baumann 2008-06-04 12:26:52 EDT
Description of problem:
Gdm crashes if a user has a home directory on a filesystem which is not known to
gio, such as afs.

Version-Release number of selected component (if applicable):
2.22.0-5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Have one or more user(s) with their home directory on an AFS server.
2. Try to start gdm
  
Actual results:
Gdm crashes

Expected results:
Gdm runs ;)
Comment 1 Danny Baumann 2008-06-04 12:26:52 EDT
Created attachment 308367 [details]
Fix segfault by assuming a non-local filesystem for unknown filesystems (in doubt, take the safe choice)
Comment 2 Avi Kivity 2008-09-29 03:41:53 EDT
Encountered same problem here, debugged, and generated exaclty the same patch.  Please apply the patch so that other people don't have to waste time on this.
Comment 3 Ray Strode [halfline] 2008-09-29 09:59:53 EDT
Thanks Danny.

Looks like this patch has already gone upstream.

Avi, would you like us to do an F9 update with this fix included?
Comment 4 Avi Kivity 2008-09-29 10:17:35 EDT
Yes please.  While I got my laptop sorted out, I'd like to change more machines.  Not to mention that this might happen to other unsuspecting users.
Comment 5 Fedora Update System 2008-09-29 12:05:11 EDT
gdm-2.22.0-10.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gdm-2.22.0-10.fc9
Comment 6 Fedora Update System 2008-10-01 02:32:50 EDT
gdm-2.22.0-10.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8449
Comment 7 Fedora Update System 2008-10-03 18:30:52 EDT
gdm-2.22.0-10.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.