Bug 450051 - Swap space used keeps growing and eventually kills the process [NEEDINFO]
Swap space used keeps growing and eventually kills the process
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
high Severity high
: rc
: ---
Assigned To: Larry Woodman
Red Hat Kernel QE team
:
Depends On:
Blocks: 533192 483701
  Show dependency treegraph
 
Reported: 2008-06-04 18:51 EDT by Radha Srinivasan
Modified: 2014-06-02 09:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (rsrinivasan)


Attachments (Terms of Use)

  None (edit)
Description Radha Srinivasan 2008-06-04 18:51:23 EDT
Description of problem:

> We are running Vertica Database on a 4 node cluster. Each machine has 
> 8 GB RAM and 8 GB swap space running RH5.0.
> 
> We have set /proc/sys/vm/swappiness = 0
> 
> When we start Vertica database and start loading data and running 
> queries the % swap used slowly climbs and reaches  over 50% (from sar 
> -r
> command) and eventually we start thrashing and the kernel kills the 
> Vertica process.
> 
> We have another 4 node cluster with same configuration but with
> FedoraCore6 OS and with same setting /proc/sys/vm/swappiness = 0.
> 
> On this configuration the % swap used remains at < 1% and Vertica 
> process runs successfully without any failure.
> 
> The failure on RH5 system has occurred any time between 8 hours to 48 
> hours of running the tests.
> 

Version-Release number of selected component (if applicable):
Linux dell03 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007 x86_64 x86_64
x86_64 GNU/Linux


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Larry Woodman 2008-06-06 07:49:49 EDT
Please reproduce this problem and attach the showmem outout that is written to
the console when the OOM kill occurs.  That will provide us the information to
determine where the resources are at time the process is killed.

Larry Woodman
Comment 6 RHEL Product and Program Management 2009-02-16 10:24:02 EST
Updating PM score.
Comment 7 shyam parate 2009-06-25 15:47:56 EDT
I m facing the same problem in my laptop with fedora 11 installed.Swap memory slowly climbs and slow down the system and eventually kills process.I have RAM of 1 Gb n swap of 1Gb with sytem comprising of Intel Core 2 Duo T5500(1.66 Ghz, 667 Mhz, 2 MB L2 Cache)

Any solution till now?

Thanks.
Comment 11 RHEL Product and Program Management 2014-03-07 08:35:47 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 12 RHEL Product and Program Management 2014-06-02 09:04:02 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.