Bug 45006 - fileutils SRPM needs build-dependency on libtermcap-devel
fileutils SRPM needs build-dependency on libtermcap-devel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-19 11:41 EDT by Jay Turner
Modified: 2015-01-07 18:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-21 09:14:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen Foster 2001-06-19 11:41:46 EDT
Description of Problem: with the 7.1 product, you cannot build the
fileutils SRPM without having libtermcap-devel installed.   But, if "rpm
-ba /usr/src/redhat/SPECS/fileutils*spec" is executed, you do NOT get an
error from rpm about missing/unsatisfied build dependencies.  If you
install the libtermcap-devel rpm, the fileutils SRPM builds without
problems.

How Reproducible: Always

Steps to Reproduce:
   1. rpm -e libtermcap-devel
   2. rpm -Uvh <tree-path>/SRPMS/fileutils*.src.rpm
   3. rpm -ba /usr/src/redhat/SPECS/fileutils*spec
   4. rpm -Uvh <tree-path>/RedHat/RPMS/libtermcap-devel*
   5. rpm -ba /usr/src/redhat/SPECS/fileutils*spec

Actual Results:
first 3 steps result in a failure WITHOUT a build-requires error from rpm
next 2 steps build the SRPM without fail

Expected Results:  I would expect an rpm error message to be written to
stderr informing me the fileutils SRPM cannot be built without installing
the libtermcap-devel RPM.
Comment 1 Bernhard Rosenkraenzer 2001-06-26 12:21:06 EDT
fileutils compiles if either libtermcap-devel or ncurses-devel is installed.
Since they don't provide anything common, and there's no "BuildRequires: 
libtermcap-devel || ncurses-devel" tag, I'm not 100% sure that this is the 
right thing to do.

I'm adding it, though - after all, if fileutils is compiled without 
libtermcap-devel, it'll be linked against ncurses, which is not what we're 
doing in the official packages.


Note You need to log in before you can comment on or make changes to this bug.