Bug 450073 - wxPython cannot be imported: fails with AttributeError
wxPython cannot be imported: fails with AttributeError
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wxPython (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
:
: 450074 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 01:32 EDT by Michel Alexandre Salim
Modified: 2008-06-20 15:13 EDT (History)
0 users

See Also:
Fixed In Version: 2.8.7.1-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 15:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-06-05 01:32:34 EDT
Description of problem:
Trying to import wxPython results in an error when it gets to _misc.py:

AttributeError: 'module' object has no attribute 'DateTime_GetNumberOfDaysinYear

This is preventing wxPython-based applications like londonlaw from running.

Version-Release number of selected component (if applicable):
2.8.7.1-2


How reproducible:
Always

Steps to Reproduce:
1. python
2. import wxPython
  
Actual results:
AttributeError

Expected results:
Import should work

Additional info:
Comment 1 Hans de Goede 2008-06-12 18:09:48 EDT
The fix for this is trivial, in _misc.py at line 456
"DateTime_GetNumberOfDaysinYear" should become "DateTime_GetNumberOfDaysInYear"
notice the capital I in In!

Given the trivialness of this fix (and the current unusability of the wxPython
compat part of wxPython), I've taken the liberty of commiting to CVS and
building this for F-8, F-9 and devel.

Matthew, if its ok with you I will push the F-8 and F-9 builds as update (put
them in bodhi), ok?
Comment 2 Hans de Goede 2008-06-12 18:13:01 EDT
*** Bug 450074 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2008-06-13 02:49:10 EDT
wxPython-2.8.7.1-5.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-13 02:49:23 EDT
wxPython-2.8.7.1-5.fc8 has been submitted as an update for Fedora 8
Comment 5 Hans de Goede 2008-06-13 02:51:14 EDT
I've taken the liberty to create updates in bodhi for this for F-8 and F-9, for
now they are scheduled to go to testing. Matthew, as soon as I get an ok from
you I'll push them to stable.

See:
https://admin.fedoraproject.org/updates/F9/pending/wxPython-2.8.7.1-5.fc8
https://admin.fedoraproject.org/updates/F9/pending/wxPython-2.8.7.1-5.fc9
Comment 6 Fedora Update System 2008-06-14 00:16:09 EDT
wxPython-2.8.7.1-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wxPython'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5316
Comment 7 Fedora Update System 2008-06-20 15:06:07 EDT
wxPython-2.8.7.1-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-06-20 15:13:37 EDT
wxPython-2.8.7.1-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.