This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450074 - londonlaw not working: import wxPython fails
londonlaw not working: import wxPython fails
Status: CLOSED DUPLICATE of bug 450073
Product: Fedora
Classification: Fedora
Component: londonlaw (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 01:36 EDT by Michel Alexandre Salim
Modified: 2008-06-12 18:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 18:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-06-05 01:36:55 EDT
Description of problem:
london-client cannot be started, as importing wxPython immediately throws an
AttributeError: bz #450073

'import wxPython' is deprecated and suggested to be replaced with 'import wx'
(http://objectmix.com/python/318022-error-wxpython2-8-win32-unicode-2-8-7-1-py25-exe.html);
is there an updated version of londonlaw available?

Version-Release number of selected component (if applicable):
0.2.1-3

How reproducible:
Always

Steps to Reproduce:
1. From console, london-client
  
Actual results:
Deprecation warning, AttributeError

Expected results:
Should work

Additional info:
Comment 1 Michel Alexandre Salim 2008-06-05 02:07:15 EDT
An unrelated issue, but trivial enough not to open a new bug entry for it: the
URL in the package is no longer valid, game homepage is now at 
http://pessimization.com/software/londonlaw/

(0.2.1 is still the latest version, and the TLA archive hosted on UMich is no
longer available too)
Comment 2 Hans de Goede 2008-06-12 18:13:00 EDT
(In reply to comment #1)
> An unrelated issue, but trivial enough not to open a new bug entry for it: the
> URL in the package is no longer valid, game homepage is now at 
> http://pessimization.com/software/londonlaw/
> 

Thanks, fixed in CVS. For the rest this is not a londonlaw bug, but a wxPython
one, as you reported in bug 450073, marking this as a dup of bug 450073.


*** This bug has been marked as a duplicate of 450073 ***

Note You need to log in before you can comment on or make changes to this bug.