Bug 450075 - spurious keyboard light for capslock mapped to ctrl
spurious keyboard light for capslock mapped to ctrl
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 01:56 EDT by Roland McGrath
Modified: 2018-04-11 07:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.5.0-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 21:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2008-06-05 01:56:07 EDT
I'm not really sure whose problem this is, but seems like the X server.

Vanilla gnome desktop, configured with System->Preferences->Hardware->Keyboard,
go to Layouts tab, hit "Layout Options..." button, "Ctrl key position" and
select "Make CapsLock an additional Ctrl".

With this configuration, the keys work fine.  But, the keyboard light for
capslock toggles every time I use the Ctrl key (physical capslock).

This does not happen in Fedora 8 using the same configuration.

Same thing seen on i386 and x86_64 on different hardware.
Comment 1 Matěj Cepl 2008-06-05 10:23:50 EDT
Can fully reproduce here. And actually, I had exactly the same problem with
Fedora 8.
Comment 2 David Perkinson 2008-08-09 14:54:14 EDT
Same problem here on both a Dell desktop and a Thinkpad X40 laptop.  There is some relevant discussion here:

http://ubuntuforums.org/showthread.php?t=737480
Comment 3 Peter Hutterer 2008-09-09 03:31:56 EDT
This commit in rawhide should have fixed this issue, it certainly works in RH now.

* Tue Aug 05 2008 Peter Hutterer <peter.hutterer@redhat.com> 1.4.99.906-5
- xserver-1.5.0-xkb-fix-ProcXkbSetXYZ-to-work-on-all.patch: force xkb requests
  to apply to all extension devices.
Comment 4 David Perkinson 2008-09-13 19:43:02 EDT
It's still a problem for me (2.6.26.3-29.fc9.i686).
Comment 5 Peter Hutterer 2008-09-14 20:10:50 EDT
xorg-x11-server-Xorg has been updated to 1.5.0 in F-9. 

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-8032

Please give it a try and let us know if the issue is fixed.
Comment 6 Roland McGrath 2008-09-17 21:05:41 EDT
Shazam!  Pas de blinkenlight!

rhgb stopped happening on boot after this update, but that is, I presume, an unrelated issue, and is also one I don't actually care about.
Comment 7 David Perkinson 2008-09-19 11:37:21 EDT
The problem is solved as far as I can see.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.