Bug 450123 - Long operations or operations that don't complete should have a cancel button
Long operations or operations that don't complete should have a cancel button
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Hugh Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 10:22 EDT by Benjamin Kahn
Modified: 2010-03-16 13:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 17:23:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2008-06-05 10:22:07 EDT
Description of problem:
Long operations or operations that don't complete should have a cancel button

Version-Release number of selected component (if applicable):
HEAD

Steps to Reproduce:
1. I went to "default" on the tree
2. picked the "User Access" tab
3. Clicked "Add User"
  
Actual results:
The screen turned mostly dark and the model dialog with the spinner appeared. 
And never completed.

Expected results:
Even if an operation jams, it should be able to be canceled.

Additional info:
Comment 1 Scott Seago 2008-10-02 11:32:48 EDT
Actually this probably wasn't an action getting jammed -- it was probably a server error that the UI popup didn't recover properly from.
Comment 2 Hugh Brock 2008-10-16 17:23:52 EDT
Closing this since as Scott says the real bug was a server error, and we have now provided cancel buttons on all facebox popups. I agree with the statement though.

Note You need to log in before you can comment on or make changes to this bug.