This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450177 - Invalid URL in activation key leads to 404
Invalid URL in activation key leads to 404
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Justin Sherrill
Preethi Thomas
:
Depends On:
Blocks: 429319
  Show dependency treegraph
 
Reported: 2008-06-05 14:16 EDT by Patrick Connelly
Modified: 2008-08-13 15:09 EDT (History)
0 users

See Also:
Fixed In Version: sat511
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 15:04:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Connelly 2008-06-05 14:16:39 EDT
Description of problem:
Invalid URL for delete activation key generates a 404.  Looks like a remnant
from when it was changed from perl to java


Version-Release number of selected component (if applicable):


How reproducible:
Everytime


Steps to Reproduce:
1. Create activation key with provisioning entitlement.  
2. Goto configuration tab.  
3. Click 'delete key'.  

Actual results:
User gets 404 error

Expected results:
Key gets deleted

Additional info:
URL points to '/network/account/activation_keys/delete.pxt' not
'/rhn/activationkeys/Delete.do'
Comment 1 Justin Sherrill 2008-06-05 14:49:22 EDT
fixed in rev 173560 and backported in rev 173562.
Comment 2 Preethi Thomas 2008-06-12 15:25:40 EDT
verified
Comment 3 Pradeep Kilambi 2008-07-21 11:12:52 EDT
key deleted successfully. verified
Comment 4 Brandon Perkins 2008-08-13 15:04:15 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.
Comment 5 Brandon Perkins 2008-08-13 15:09:17 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.