Bug 450179 - Deletion of activation key either deletes config channel or results in an ISE
Deletion of activation key either deletes config channel or results in an ISE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Partha Aji
Jeff Browning
:
Depends On:
Blocks: 429319
  Show dependency treegraph
 
Reported: 2008-06-05 14:24 EDT by Patrick Connelly
Modified: 2008-08-13 15:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat511
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 15:04:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Connelly 2008-06-05 14:24:29 EDT
Description of problem:
If an activation key is associated with a configuration channel, and the
activation key is deleted, the configuration channel will be deleted.  Or, if
there are any files associated with the config channel, it will fail with and
ISE and the following in catalina.out

ORA-02292: integrity constraint (RHNSAT.RHN_CONFFILE_CCID_FK) violated 


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
Steps #1
1. Create Configuration channel
2. Create a text file inside the config channel
3. Create activation key with provisioning entitlement
4. Associate the config channel with the activation key
5. Delete the activation key
  
Steps #2
1. Create Configuration channel
2. Create activation key with provisioning entitlement
3. Associate the config channel with the activation key
4. Delete the activation key

Actual results:

Steps #1
ISE

Steps #2
Config channel gets deleted

Expected results:
Activation key gets deleted but config channel stays

Additional info:
Looks like a database constrain issue is causing the ISE.  Probably a cascade
from the database removal causes the deletion of the config channel
Comment 2 Partha Aji 2008-06-09 11:29:06 EDT
Moving to ON_QA
Comment 3 Jeff Browning 2008-06-17 16:22:32 EDT
Still getting the same behavior described in the original ticket. Tested on
rlx-3-08.
Comment 5 Jeff Browning 2008-07-01 13:18:47 EDT
Verified both cases
Comment 6 Preethi Thomas 2008-07-22 07:51:38 EDT
release pending
Comment 7 Brandon Perkins 2008-08-13 15:04:16 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.
Comment 8 Brandon Perkins 2008-08-13 15:09:18 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.