Bug 450255 - lack of management entitlements and universal default key gives misleading error description with rhnreg_ks
lack of management entitlements and universal default key gives misleading er...
Status: CLOSED DUPLICATE of bug 170583
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 05:11 EDT by Jan Hutař
Modified: 2008-06-06 16:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 16:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-06-06 05:11:46 EDT
Description of problem:
Lack of "Management" base entitlements with "Universal default" activation key 
on RHN server gives misleading error description when running rhnreg_ks


Version-Release number of selected component (if applicable):
up2date-4.6.2-7.el4_6.1


How reproducible:
always


Steps to Reproduce:
1. You have RHN Server with 1 "Management" and few (~10) "Update" base 
entitlements
2. You have an universal default activation key
     Systems -> Activation Keys -> <your_key> -> Universal Default: YES
   (this means that this key will be used for *all* newly registered
   systems, and they will have "Management" base entitlement instead of
   simple "Update"; note the prefix of your key, in my case it was 123)
3. # rhnreg_ks --force --activationkey=123-<your_key>
   (this shoud PASS, as we still have 1 available "Management"
   base entitlements)
4. # rhnreg_ks --force --activationkey=123-<your_key>
   (this shoud FAIL and we are interested in the error message it shows)
  If the error messge is something like this:
Error Message:
    Registration failed: RHN Software Management service entitlements exhausted
Error Class Code: 91
Error Class Info: Registration token unable to entitle system: maximum
                  membership exceeded
Explanation:
    Your organization does not have enough Management entitlements to register 
this
    system to Red Hat Network. Please notify your organization administrator of 
this error. 
    You should be able to register this system after your organization frees 
existing 
    or purchases additional entitlements. Additional entitlements may be 
purchased by your
    organization administrator by logging into Red Hat Network and visiting
    the 'Subscription Management' page in the 'Your RHN' section of RHN.
    
    A common cause of this error code is due to having mistakenly setup an
    Activation Key which is set as the universal default.  If an activation key 
is set
    on the account as a universal default, you can disable this key and retry 
to avoid
    requiring a Management entitlement.
  then PASS
  Else (error message is something like this):
Error Message:
    Registration failed: RHN Software Management service entitlements exhausted
Error Class Code: 91
Error Class Info: Registration token unable to entitle system: maximum 
membership exceeded
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
  then FAIL


Additional info:
This was actually fixed in the 2008:8295 up2date advisory, in 
up2date-4.7.1-3.el4, as a part of bug 170583.

Bug 170583: same issue for `up2date --register`/`rhn_register`
This bug: this is a `rhnreg_ks` part of the bug
Comment 2 Pradeep Kilambi 2008-06-06 16:44:50 EDT

*** This bug has been marked as a duplicate of 170583 ***

Note You need to log in before you can comment on or make changes to this bug.