Bug 450299 - Upgrade of proxy on rhel5 do not work
Upgrade of proxy on rhel5 do not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Steve Salevan
:
Depends On:
Blocks: 446861 446878
  Show dependency treegraph
 
Reported: 2008-06-06 11:02 EDT by Miroslav Suchý
Modified: 2008-11-05 13:40 EST (History)
1 user (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:40:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-06-06 11:02:21 EDT
Description of problem:
When you have some conflicting packages on machine RHEL5, the installer will
fail, becouse of unresolvable dependencies. 

Version-Release number of selected component (if applicable):
520

Steps to Reproduce:
1. install proxy on rhel5
2. deactivate (do not remove packages)
3. install again using webui
  
Actual results:
error: Failed dependencies:
 httpd is needed by (installed) rhns-proxy-html-5.2.0-5.el5.noarch
 libidn.so.11 is needed by (installed) jwhois-3.2.3-8.el5.i386
 libidn.so.11 is needed by (installed) curl-7.15.5-2.el5.i386
 libidn.so.11 is needed by (installed) gnupg-1.4.5-12.i386
 perl(Apache2::Const) is needed by (installed) perl-Frontier-RPC-0.07-7.noarch
 perl(Apache2::ServerUtil) is needed by (installed) perl-Frontier-RPC-0.07-7.noarch
 mod_python is needed by (installed) rhns-proxy-common-5.2.0-4.el5.noarch
 mod_ssl is needed by (installed) rhns-proxy-common-5.2.0-4.el5.noarch
 rhns-proxy-broker >= 5.2.0 is needed by (installed)
rhns-proxy-common-5.2.0-4.el5.noarch

Expected results:
no error
Comment 1 Miroslav Suchý 2008-06-06 11:13:17 EDT
commited to trunk rev. 173634
Comment 2 Brandon Perkins 2008-06-09 18:12:36 EDT
Removing Bug 450299 blocks bug 450531.  Removing Bug 450299 depends on bug
446878.  Adding Bug 450299 blocks bug 446878.
Comment 3 Brad Buckingham 2008-08-13 12:54:07 EDT
Mass move to ON_QA.
Comment 4 Steve Salevan 2008-08-29 10:43:39 EDT
Followed test plan, proxy reinstalled successfully.  Moving to VERIFIED.
Comment 5 Preethi Thomas 2008-10-23 09:49:13 EDT
followed the test plan.
release pending
Comment 6 Brandon Perkins 2008-11-05 13:40:28 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.