Bug 450327 - Unlimited respawning of gdm
Unlimited respawning of gdm
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 13:55 EDT by David Lutterkort
Modified: 2014-06-18 04:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 01:12:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lutterkort 2008-06-06 13:55:45 EDT
Description of problem:

For as yet unknown reasons, gdm was crashing on my laptop. upstart failed to
limit the respawns, causing gdm to be restarted continually

Version-Release number of selected component (if applicable):
upstart-0.3.9-19.fc9.x86_64
gdm-2.22.0-5.fc9.x86_64


I put the relevant parts of /var/log/messages at
http://lutter.fedorapeople.org/messages-gdm-crash.log.gz
Comment 1 David Lutterkort 2008-06-06 14:05:02 EDT
I opened bz 450330 for the gdm problem
Comment 2 Casey Dahlin 2008-06-06 15:30:08 EDT
We just need to set a respawn limit then. If I could just find documentation on
the syntax :)

I'll have a patch for this when I get up with Scott.
Comment 3 David Lutterkort 2008-06-06 15:51:16 EDT
It seems that there is a limit set already. My /etc/event.d/prefdm (which is the
one from initscripts-8.76.2-1.x86_64) has the line 'respawn limit 10 120'
Comment 4 Bill Nottingham 2008-06-06 15:54:04 EDT
If you get it into this state, (where it's constantly respawning) what's the
output of 'initctl status prefdm'?
Comment 5 Casey Dahlin 2008-06-06 15:56:48 EDT
(In reply to comment #3)
> It seems that there is a limit set already. My /etc/event.d/prefdm (which is the
> one from initscripts-8.76.2-1.x86_64) has the line 'respawn limit 10 120'
> 

So I just saw. It should be respawning no more than 10 times per 2 minutes.
Comment 6 Scott James Remnant 2008-06-06 16:10:18 EDT
Could you attach the /etc/event.d/prefdm file for me?
Comment 7 Bill Nottingham 2008-06-06 16:15:57 EDT
# prefdm - preferred display manager
#
# Starts gdm/xdm/etc by preference

start on stopped rc5

stop on runlevel [!5]

console output
respawn
respawn limit 10 120
exec /etc/X11/prefdm -nodaemon
Comment 8 David Lutterkort 2008-06-06 18:39:41 EDT
(In reply to comment #4)
> If you get it into this state, (where it's constantly respawning) what's the
> output of 'initctl status prefdm'?

I couldn't get that information - I can't type anything on a local vt since gdm
takes the screen over faster than I can type, and even when I log in from
another box, the respawning somehow cut the ssh connection. I tried to capture
that output by running the initctl in the background, booting first into
runlevel 3 and then doing a 'telinit 5', but because I had messed with my
homedir in /etc/passwd gdm now does not crash anymore (even after switching back
to the original homedir)

So .. nothing but a mystery. I am wondering if at least the respawning part
could be simulated by replacing /etc/X11/prefdm with a script that just exits.
Comment 9 Scott James Remnant 2008-06-06 19:19:14 EDT
Could you edit the /etc/event.d/prefdm file and add this line to the end:

  post-stop exec sleep 10

That will introduce a 10s delay between each respawn, so should give you ample
time to get a console.
Comment 10 Casey Dahlin 2008-10-19 14:09:07 EDT
Marking as needinfo, since we still haven't heard back about Scott's requiest.

David, are you still experiencing this issue?
Comment 11 David Lutterkort 2008-10-20 20:00:01 EDT
I haven't been able to reproduce this for some time now. Feel free to close it.

Note You need to log in before you can comment on or make changes to this bug.