Bug 450342 - %pre script fails for asterisk-zaptel
%pre script fails for asterisk-zaptel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: asterisk (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 15:31 EDT by Andy Burns
Modified: 2008-06-06 22:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 15:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Burns 2008-06-06 15:31:19 EDT
Description of problem:
When installing the asterisk-zaptel package, the %pre script fails, this script
attempts to execute "usermod -a -G zaptel asterisk" however my install of zaptel
(from atrpms) appears not to have created the zaptel group, I corrected this
manually by "groupadd -r zaptel", then it installed OK

Version-Release number of selected component (if applicable):
zaptel.x86_64                            1:1.4.10-50.fc7
asterisk-zaptel.x86_64                   1.6.0-0.13.beta8.fc9
Comment 1 Jeffrey C. Ollie 2008-06-06 15:37:55 EDT
Mixing Zaptel/libpri/Asterisk RPMs from Fedora and ATRPMs is not recommended as
they make different assumptions about how the system is set up.  If you need the
Zaptel RPMs from ATRPMs to get the kernel modules that Fedora does not have,
please use the Asterisk from ATRPMs as well.
Comment 2 Andy Burns 2008-06-06 18:43:41 EDT
Fair comment about being careful mixing repos, but I use asterisk 1.6 for the
AsyncAGI feature.

I'm curious what purpose the Fedora asterisk-zaptel package provides *without*
the zaptel package installed from somewhere else?

I have no need of any zaptel kernel modules, as I'm not using any hardware
interfaces, I just need asterisk-zaptel installed to allow IAX2 with trunk=yes.

Comment 3 Jeffrey C. Ollie 2008-06-06 19:09:35 EDT
(In reply to comment #2)
> Fair comment about being careful mixing repos, but I use asterisk 1.6 for the
> AsyncAGI feature.
> 
> I'm curious what purpose the Fedora asterisk-zaptel package provides *without*
> the zaptel package installed from somewhere else?

The zaptel userspace libraries were included in Fedora so that Asterisk would
work with Zaptel hardware if the Zaptel kernel modules were obtained elsewhere.
 It was hoped that Digium would get the Zaptel modules included in the vanilla
kernel but that seems like it won't happen now.

> I have no need of any zaptel kernel modules, as I'm not using any hardware
> interfaces, I just need asterisk-zaptel installed to allow IAX2 with trunk=yes.

Actually, the IAX2 trunking does require kernel modules because it uses the
Zaptel modules as a source of timing.
Comment 4 Andy Burns 2008-06-06 22:13:32 EDT
(In reply to comment #3)

> The zaptel userspace libraries were included in Fedora so that Asterisk would
> work with Zaptel hardware if the Zaptel kernel modules were obtained 
> elsewhere.

Then I found it slightly odd that you dismissed my initial issue.

> Actually, the IAX2 trunking does require kernel modules because it uses the
> Zaptel modules as a source of timing.

OK, thanks for the info, I got a warning about needing zaptel for trunking, the
warning went away after I installed asterisk-zaptel (without any kernel modules)
Comment 5 Jeffrey C. Ollie 2008-06-06 22:23:08 EDT
(In reply to comment #4)
> (In reply to comment #3)
> 
> > The zaptel userspace libraries were included in Fedora so that Asterisk would
> > work with Zaptel hardware if the Zaptel kernel modules were obtained 
> > elsewhere.
> 
> Then I found it slightly odd that you dismissed my initial issue.

The ATRPMs Zaptel packages, while they include the Zaptel kernel modules, aren't
compatible with the Fedora Asterisk packages.  The Fedora Zaptel packages are
set up differently so that they will work with CallWeaver as well.  That's why
the asterisk-zaptel package is expecting a zaptel group to exist rather than an
asterisk group.

Note You need to log in before you can comment on or make changes to this bug.