Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 450365 - rpm-based kernel upgraded cause kernel fault due to initrd busybox fault
Summary: rpm-based kernel upgraded cause kernel fault due to initrd busybox fault
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mkinitrd
Version: 4.6
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-07 02:58 UTC by Jason Haar
Modified: 2011-07-27 18:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-27 18:01:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jason Haar 2008-06-07 02:58:09 UTC
Description of problem:

We're using HAVP as an AV proxy, which requires the root fs to be mounted "mand"
- mandatory locks. However, when a kernel upgrade occurs, the initrd
auto-generated includes the "mand" option - and busybox's mount command doesn't
support mand. So initrd cannot mount the root fs and crashes!

Version-Release number of selected component (if applicable):


How reproducible:

every kernel upgrade is unusable.

Steps to Reproduce:
1. mount -oremount,mand /
2. upgrade kernel
3. reboot
  
Actual results:

fails to book

Expected results:

should boot

Additional info:

either busybox should support every FS option that the kernel supports, or the
kernel installer should be smart enough to only "remember" fs options busybox
supports.

Comment 1 Ivana Varekova 2008-06-12 13:40:07 UTC
Hello, I'm not sure why busybox is used here - there is no reason to be used
busybox. So please do you know what is the cause/ do you use some special
setting? (I'm not sure whether I have not overlook something but if you use the
steps you attach here in Steps to Reproduce, then the busybox is not called at all).

Comment 2 Jason Haar 2008-06-12 22:38:05 UTC
I'm sorry, I assumed it was busybox due to my previous experience with mkcdrec -
which uses busybox to keep the initrd size down

I've just unpacked initrd and I see there's no /bin/mount in there, so I assume
it must be a built-in function of /bin/nash?

So it's the "mount" functionality of nash that doesn't support the more esoteric
FS options - such as "mand"?



Comment 3 Ivana Varekova 2008-06-13 07:49:02 UTC
Change the component to mkinitrd.


Note You need to log in before you can comment on or make changes to this bug.