Bug 450392 - kernel rpm still detect wrong arch - intel p4
kernel rpm still detect wrong arch - intel p4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 09:42 EDT by Frank DiPrete
Modified: 2008-08-06 17:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 17:12:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank DiPrete 2008-06-07 09:42:58 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. try to install/update fc8 Intel(R) Pentium(R) 4 CPU 3.00GHz
2.
3.
  
Actual results:
does not install i686 kernel

Expected results:
install i686 kernel


Additional info:
Comment 1 Frank DiPrete 2008-06-07 09:43:42 EDT
[root@gilligan rpms]# rpm -i kernel-2.6.25.4-10.fc8.i686.rpm
        package kernel-2.6.25.4-10.fc8.i686 is intended for a i686 architecture
[root@gilligan rpms]# arch
i686
[root@gilligan rpms]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 9
cpu MHz         : 3000.335
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pebs
bts sync_rdtsc pni monitor ds_cpl cid cx16 xtpr lahf_lm
bogomips        : 6003.68
clflush size    : 64

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 9
cpu MHz         : 3000.335
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pebs
bts sync_rdtsc pni monitor ds_cpl cid cx16 xtpr lahf_lm
bogomips        : 5999.33
clflush size    : 64

[root@gilligan rpms]# 

Comment 2 Dave Jones 2008-06-07 13:35:28 EDT
it looks like you installed the 64 bit version of Fedora.
You need to install the x86_64 version of the rpm.
Comment 3 Chuck Ebbert 2008-06-07 21:13:03 EDT
Can you post the output of the command:

  yum list installed kernel

Comment 4 Frank DiPrete 2008-06-08 08:43:08 EDT
[root@gilligan ~]# yum list installed kernel
Installed Packages
kernel.i686                              2.6.23.1-42.fc8        installed       

Comment 5 Frank DiPrete 2008-06-08 08:44:47 EDT
[root@gilligan ~]# rpm -qa | grep kernel
kernel-2.6.23.1-42.fc8
kernel-headers-2.6.25.4-10.fc8

the 2.6.25.4 kernel headers installed but not the kernel rpm due to arch detect
problem.
Comment 6 Dave Jones 2008-06-08 11:49:26 EDT
what does uname -a say ?
Comment 7 Frank DiPrete 2008-06-08 12:01:53 EDT
[root@skipper ~]# uname -a
Linux skipper 2.6.25.4-10.fc8 #1 SMP Thu May 22 23:34:09 EDT 2008 i686 i686 i386
GNU/Linux

Comment 8 Frank DiPrete 2008-06-08 12:05:05 EDT
dmesg on the subject of CPU's:


CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 2048K
CPU: Physical Processor ID: 0
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (24) available
CPU0: Thermal monitoring enabled
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
ACPI: Core revision 20070126
CPU0: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 03
Booting processor 1/1 ip 4000
CPU 1 irqstacks, hard=c07bd000 soft=c079d000
Initializing CPU#1
Calibrating delay using timer specific routine.. 5999.15 BogoMIPS (lpj=2999578)
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 2048K
CPU: Physical Processor ID: 0
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#1.
CPU1: Intel P4/Xeon Extended MCE MSRs (24) available
CPU1: Thermal monitoring enabled
CPU1: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 03
Total of 2 processors activated (12004.57 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
checking TSC synchronization [CPU#0 -> CPU#1]: passed.
Brought up 2 CPUs


Comment 9 Dave Jones 2008-06-08 12:28:00 EDT
[root@gilligan rpms]# rpm -i kernel-2.6.25.4-10.fc8.i686.rpm

[root@skipper ~]# uname -a

you've done this on two separate hosts.
what does the uname say on gilligan ?
Comment 10 Frank DiPrete 2008-06-08 12:49:16 EDT
my bad - gilligan is the troubled host

[root@gilligan ~]# uname -a
Linux gilligan 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:55:12 EDT 2007 i686 i686
i386 GNU/Linux

Initializing CPU#0
CPU 0 irqstacks, hard=c07a8000 soft=c0788000
PID hash table entries: 4096 (order: 12, 16384 bytes)
Detected 3000.335 MHz processor.
Console: colour VGA+ 80x25
console [tty0] enabled
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 1029384k/1046716k available (2183k kernel code, 16528k reserved, 1117k d
ata, 280k init, 129212k highmem)
virtual kernel memory layout:
    fixmap  : 0xffc53000 - 0xfffff000   (3760 kB)
    pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
    vmalloc : 0xf8800000 - 0xff7fe000   ( 111 MB)
    lowmem  : 0xc0000000 - 0xf8000000   ( 896 MB)
      .init : 0xc073f000 - 0xc0785000   ( 280 kB)
      .data : 0xc0621f7d - 0xc0739544   (1117 kB)
      .text : 0xc0400000 - 0xc0621f7d   (2183 kB)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
SLUB: Genslabs=22, HWalign=64, Order=0-1, MinObjects=4, CPUs=2, Nodes=1
Calibrating delay using timer specific routine.. 6003.68 BogoMIPS (lpj=3001843)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 512
CPU: After generic identify, caps: bfebfbff 20100000 00000000 00000000 0000641d 
00000000 00000001 00000000
monitor/mwait feature present.
using mwait in idle threads.
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: After all inits, caps: bfebf3ff 20100000 00000000 0000b180 0000641d 0000000
0 00000001 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (24) available
CPU0: Thermal monitoring enabled
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
ACPI: Core revision 20070126
CPU0: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 09
SMP alternatives: switching to SMP code
Booting processor 1/1 eip 3000
CPU 1 irqstacks, hard=c07a9000 soft=c0789000
Initializing CPU#1
Calibrating delay using timer specific routine.. 5999.33 BogoMIPS (lpj=2999667)
CPU: After generic identify, caps: bfebfbff 20100000 00000000 00000000 0000641d 
00000000 00000001 00000000
monitor/mwait feature present.
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: After all inits, caps: bfebf3ff 20100000 00000000 0000b180 0000641d 0000000
0 00000001 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#1.
CPU1: Intel P4/Xeon Extended MCE MSRs (24) available
CPU1: Thermal monitoring enabled
CPU1: Intel(R) Pentium(R) 4 CPU 3.00GHz stepping 09
Total of 2 processors activated (12003.02 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
checking TSC synchronization [CPU#0 -> CPU#1]: passed.
Brought up 2 CPUs
Comment 11 Dave Jones 2008-06-08 13:05:46 EDT
hmm. I'm out of ideas.  maybe the rpm maintainers have some insight.
Comment 12 Frank DiPrete 2008-06-09 08:41:55 EDT
I found the problem.

The file, /etc/rpm/platform , contained:
i586-redhat-linux

which is incorrect.

changing it to:
i686-redhat-linux

fixed the problem.

[root@gilligan ~]# rpm -Uvh kernel-2.6.25.4-10.fc8.i686.rpm 
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]

It looks like anaconda does not update that file correctly and the kernel rpm
uses it's contents without question; not uname, arch or /proc/cpuino
Comment 13 Dave Jones 2008-06-09 09:03:14 EDT
Now the question is why that was set to '586' in the first place.
We had a bug several releases back (I think FC6 era?) that got that wrong.  Is
it possible this box has been updated from some ancient release like that?
Comment 14 Chuck Ebbert 2008-06-09 23:19:34 EDT
(In reply to comment #12)
> I found the problem.
> 
> The file, /etc/rpm/platform , contained:
> i586-redhat-linux
> 
> which is incorrect.
> 

Wow. The installer gave you an i686 kernel but set (or left) this as i586...
Comment 15 Chris Lumens 2008-08-06 17:12:21 EDT
As of F9, we are no longer writing out /etc/rpm/platform.

Note You need to log in before you can comment on or make changes to this bug.