Bug 450421 - gdm logins for YP users fail, xorg gets SIGTERM
gdm logins for YP users fail, xorg gets SIGTERM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 23:22 EDT by Brian Cain
Modified: 2015-01-14 18:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-28 22:03:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Cain 2008-06-07 23:22:02 EDT
Description of problem:

When attempting a graphical login of a YP user (whose home directory is
automounted via NFS), the X server appears to crash (strace indicates that it
receives SIGTERM and the screen rapidly changes modes and returns to gdm's
greeter w/o any indication of an error).

A text-mode login of YP users (locally using a different VT or remotely via ssh)
succeeds without error.  After a successful local console login, executing
'startx' brings up a GNOME desktop without error.

Version-Release number of selected component (if applicable):


How reproducible:

Out of ten trials (across multiple hardware platforms, one was the HP xw9400
workstation), all ten failed.

Steps to Reproduce:
1.configure YP, autofs (edit yp.conf, auto.master) to match network settings
2.start ypbind
3.start autofs
4.attempt graphical login at GDM greeter

Actual results:

Login attempt fails without explicit error indication.  syslog includes
complaints about inability to set some read-only screensaver...power_management
value from gconfd.  Nothing I have done has been able to address that issue, but
I'm not so sure that it's a part of the login problem.

Expected results:

Login succeeds without error.  User is presented with GNOME desktop.

Additional info:

I've tried removing .gconf*, .gnome*, from the user's home directory, none of
which appears to resolve this problem.  Complicating things is the fact that
ypbind does not typically get started by NetworkManager (though chkconfig
indicates that ypbind is 'on' for runlevels 3,4,5).  Or perhaps NetworkManager
invokes/contacts ypbind before the interface is ready for traffic?  Hopefully
there's already a bug on that issue.

The ypbind daemon was running during all of the trials described above.
Comment 1 Ray Strode [halfline] 2008-06-08 00:56:02 EDT
what version of gdm?
Comment 2 Brian Cain 2008-06-08 10:17:55 EDT
$ rpm -qa | grep gdm
gdm-2.22.0-1.fc9.x86_64
gdm-user-switch-applet-2.22.0-1.fc9.x86_64

$ cat /etc/redhat-release
Fedora release 9 (Sulphur)

$ cat /etc/gdm/custom.conf
# GDM configuration storage

[xdmcp]

[chooser]

[debug]
Comment 3 Ray Strode [halfline] 2008-06-09 11:43:18 EDT
Ah, can you try upgrading to 2.22.0-5 ?  I think it should address this issue.
Comment 4 Brian Cain 2008-06-09 14:22:16 EDT
2.22.0-5 did not address the problem.

$ rpm -qa | grep gdm

gdm-user-switch-applet-2.22.0-1.fc9.x86_64
gdm-2.22.0-5.fc9.x86_64

$ cat /etc/gdm/custom.conf
# GDM configuration storage

[xdmcp]

[chooser]

[debug]
Comment 5 Brian Cain 2008-06-28 22:05:10 EDT
Apologies.  This behavior looks like it was caused by an `exec bash` in my NIS
account's .bashrc.

Note You need to log in before you can comment on or make changes to this bug.