Bug 450467 - wireless interface won't come up
wireless interface won't come up
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 17:34 EDT by Sjoerd Mullender
Modified: 2008-06-24 09:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.25.6-57.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 09:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sjoerd Mullender 2008-06-08 17:34:17 EDT
Description of problem:
I have a Dell Inspiron 1720 laptop with an Intel PRO/Wireless 4965 wireless
interface.  When I boot the 2.6.25.3-18.fc9 kernel, the wireless interface comes
up and works.  When I boot the 2.6.25.4-30.fc9 kernel, the wireless interface
does not come up but gets a DHCP timeout.  Everything else is the same.

I do not use NetworkManager or wpa_supplicant but just the network service.

Relevant messages from dmesg:

iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.26kds
iwl4965: Copyright(c) 2003-2008 Intel Corporation
ACPI: PCI Interrupt 0000:0c:00.0[A] -> GSI 17 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:0c:00.0 to 64
iwl4965: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
iwl4965: Tunable channels: 13 802.11bg, 19 802.11a channels
phy0: Selected rate control algorithm 'iwl-4965-rs'
...
ACPI: PCI Interrupt 0000:0c:00.0[A] -> GSI 17 (level, low) -> IRQ 17
Registered led device: iwl-phy0:radio
Registered led device: iwl-phy0:assoc
Registered led device: iwl-phy0:RX
Registered led device: iwl-phy0:TX
ADDRCONF(NETDEV_UP): wlan0: link is not ready



Version-Release number of selected component (if applicable):
kernel-2.6.25.4-30.fc9.x86_64
(kernel-2.6.25.3-18.fc9.x86_64 works)

How reproducible:
100% with this kernel

Steps to Reproduce:
1.boot the system
2.watch the wlan0 interface failing after a DHCP timeout
3.
  
Alternatively: ifup wlan0

Actual results:
No wireless.

Expected results:
A working wireless interface.


Additional info:
My wireless AP which supplies the IP address through DHCP is a 802.11b interface
with WEP key and broadcast off.
Comment 1 John W. Linville 2008-06-09 10:07:23 EDT
Please attach the output of running iwconfig just before and just after (if it
looks different) running dhcp.
Comment 2 John W. Linville 2008-06-09 10:11:33 EDT
Also, please try a later kernel from Koji:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=51981

There has been lots of iwlwifi activity lately.  Does this kernel behave any
differently than -30.fc9?
Comment 3 Sjoerd Mullender 2008-06-09 12:16:17 EDT
(In reply to comment #1)
> Please attach the output of running iwconfig just before and just after (if it
> looks different) running dhcp.

ESSID and key x-ed out, but they were correct for my wireless network.

# iwconfig wlan0
wlan0     IEEE 802.11  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

# ifup wlan0

Determining IP information for wlan0...PING 192.168.2.1 (192.168.2.1) from
192.168.2.9 wlan0: 56(84) bytes of data.

--- 192.168.2.1 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3000ms
pipe 3
 failed.
# iwconfig wlan0
wlan0     IEEE 802.11  ESSID:"xxxxxx"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

# 
Comment 4 Sjoerd Mullender 2008-06-09 12:28:19 EDT
(In reply to comment #2)
> Also, please try a later kernel from Koji:
> 
>    http://koji.fedoraproject.org/koji/buildinfo?buildID=51981
> 
> There has been lots of iwlwifi activity lately.  Does this kernel behave any
> differently than -30.fc9?

Same problem with kernel-2.6.25.5-49.fc9.x86_64.  The iwconfig output also looks
the same.
Comment 5 John W. Linville 2008-06-09 14:08:40 EDT
What is the output of 'iwlist wlan0 scan'?  Are you detecting the network of
interest?

Also, do you have a line like this in /etc/modprobe.conf?

   options iwl4965 disable_hw_scan=1

Does adding/removing it make any difference?
Comment 6 Sjoerd Mullender 2008-06-09 14:55:09 EDT
# iwlist wlan0 scan
wlan0     Interface doesn't support scanning : Network is down

# ifconfig wlan0 up
# iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:14:7F:8C:9F:62
...

After the ifconfig up, the iwlist scan gives a list of APs, so scanning seems to
work.  My network is also in the list.

After this I tried the ifup wlan0 again, but that resulted in the caps lock and
scroll lock lights flashing and the system completely unresponsive.  I had to
hard reboot.  After the system was back up I tried the above commands again, but
I didn't get any scan results this time.

All of this still on the -49 kernel from koji.

# grep iwl /etc/modprobe.conf
alias wlan0 iwl4965

So no disable_hw_scan in there.
Comment 7 John W. Linville 2008-06-10 08:41:14 EDT
Please add the disable_hw_scan option to /etc/modprobe.conf and try again.  Does
it make a difference?
Comment 8 Sjoerd Mullender 2008-06-10 13:16:27 EDT
This seems to work:
# uname -r
2.6.25.4-30.fc9.x86_64
# grep iwl /etc/modprobe.conf
alias wlan0 iwl4965
options iwl4965 disable_hw_scan=1
# ifup wlan0

Determining IP information for wlan0... done.
# 
Comment 9 Sjoerd Mullender 2008-06-16 16:48:06 EDT
With the latest kernel (kernel-2.6.25.6-55.fc9.x86_64) things have gotten worse.
 If I now try ifup wlan0, the system hangs completely with the caps lock and
scroll lock leds flashing.  There is nothing I can do except hold down the power
button until the system turns off.

I can do things like ifconfig wlan0 up and then iwlist wlan0 scan (which returns
a list of APs, although I don't see mine in there--I know my AP works since I
can connect to it using another device).

The above is with the disable_hw_scan=1 option in modprobe.conf.  If I remove
the line, ifup wlan0 up doesn't hang the system but merely times out with a
"failed" message.
Comment 10 John W. Linville 2008-06-23 15:26:19 EDT
The "flashing caps lock" is a different issue.  Please try -57.fc9 or later kernels:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=52456
Comment 11 Sjoerd Mullender 2008-06-23 16:31:34 EDT
Without the disable_hw_scan=1 I still get a DHCP timeout, but with that line I
now get a working wireless interface:
# uname -r
2.6.25.6-57.fc9.x86_64
# grep iwl /etc/modprobe.conf
alias wlan0 iwl4965
options iwl4965 disable_hw_scan=1
# ifup wlan0

Determining IP information for wlan0... done.

Note You need to log in before you can comment on or make changes to this bug.