Bug 450481 - libibcommon package
libibcommon package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
noarch Linux
low Severity low
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
http://people.redhat.com/dledford/Inf...
:
Depends On: 450470
Blocks: 450482
  Show dependency treegraph
 
Reported: 2008-06-08 21:09 EDT by Doug Ledford
Modified: 2009-04-10 07:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 07:52:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ed: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Doug Ledford 2008-06-08 21:09:00 EDT
+++ This bug was initially created as a clone of Bug #450470 +++

This package is a pre-cursor, helper package to opensm, the InfiniBand subnet
manager.

src rpm can be found under

http://people.redhat.com/dledford/Infiniband/f10/SRPMS/

x86_64 rpms can be found under

http://people.redhat.com/dledford/Infiniband/f10/x86_64/
Comment 1 Ed Hill 2008-06-28 12:01:57 EDT
Here's a review (this time pasted into the correct bz entry!):

GOOD:
+ source matches upstream SHA1SUM:
    1a2b36d0f309690ad660c9c1ff177f76c2484104  libibcommon-1.1.0.tar.gz
    1a2b36d0f309690ad660c9c1ff177f76c2484104  libibcommon-1.1.0.tar.gz.UP
+ license is correct and correctly included in the main package
+ specfile looks clean and macros sane
+ proper use of ldconfig
+ *.la files are removed
+ proper use of -devel and -static
+ has %clean
+ builds in mock F8 x86_64
+ rpmlint reports just two ignore-able warnings:
    libibcommon-devel.x86_64: W: no-documentation
    libibcommon-static.x86_64: W: no-documentation
+ dir ownership looks good
+ permissions look good

NEEDSWORK:
- according to the review guidelines, the spec must have:
    rm -rf %{buildroot}
  or the equivalent at the start of %install section.
- Is the ExclusiveArch really necessary?  Could it just be deleted?
  I'm only asking because the review guidelines now include specific
  rules concerning ExcludeArch and, if the ExclusiveArch is removed,
  then I think the package will be fine wrt those guidelines.  Maybe
  a comment such as "is known to work on arches ... but has not been
  tested on ..." would be enough?
Comment 2 Doug Ledford 2008-06-28 22:15:25 EDT
Fixed the %install section

Removed the ExclusiveArch.  The software can be built anywhere, but obviously
without a hardware driver, it's useless.  The ExclusiveArch just mimicked what I
knew to be working architectures as far as the kernel and the driver situation
is concerned.
Comment 3 Ed Hill 2008-06-29 09:30:01 EDT
OK, its APPROVED.
Comment 4 Doug Ledford 2008-06-30 09:19:25 EDT
New Package CVS Request
=======================
Package Name: libibcommon
Short Description: OpenFabrics Alliance InfiniBand management common library
Owners: dledford
Branches: F-8 F-9
InitialCC:
Cvsextras Commits: yes
Comment 5 Kevin Fenzi 2008-06-30 12:16:12 EDT
cvs done.

Note You need to log in before you can comment on or make changes to this bug.