Bug 450549 - makedumpfile core_collector comment in kdump.conf incorrect
makedumpfile core_collector comment in kdump.conf incorrect
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 11:01 EDT by Andrew Hecox
Modified: 2009-01-20 16:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:00:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add --help to long options (593 bytes, patch)
2008-06-09 11:46 EDT, Andrew Hecox
no flags Details | Diff

  None (edit)
Description Andrew Hecox 2008-06-09 11:01:43 EDT
The core_collector comment in /etc/kdump.conf tells the user to use makedumpfile
--help for a list of supported core files. The correct option is '-h', not '--help'.

This happens to work currently because makedumpfile will run print_usage (plus
some additional error text) on an unrecognized option.
Comment 1 Neil Horman 2008-06-09 11:14:34 EDT
Then I think the proper fix would be adding --help to the list of long options,
rather than changing the docs...
Comment 2 Andrew Hecox 2008-06-09 11:46:44 EDT
Created attachment 308697 [details]
add --help to long options
Comment 3 Andrew Hecox 2008-06-09 11:47:13 EDT
sounds good. patch attached.
Comment 4 Andrew Hecox 2008-06-09 11:47:56 EDT
tested on RHEL 5.2 x86_64.
Comment 5 Neil Horman 2008-06-09 16:18:18 EDT
yep, thats what upstream has.  Thanks!
Comment 6 RHEL Product and Program Management 2008-06-09 16:34:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Neil Horman 2008-06-10 13:47:48 EDT
fixed in 24.el5
Comment 11 errata-xmlrpc 2009-01-20 16:00:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0105.html

Note You need to log in before you can comment on or make changes to this bug.