Bug 450556 - libvirt RPM should require nc
libvirt RPM should require nc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.2
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
: EasyFix
Depends On:
Blocks: 449772
  Show dependency treegraph
 
Reported: 2008-06-09 12:13 EDT by Ian Pilcher
Modified: 2009-12-14 16:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:22:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2008-06-09 12:13:31 EDT
Description of problem:
libvirt depends on nc to enable "remote virt-manager" over ssh; libvirt RPM
should require nc.

Version-Release number of selected component (if applicable):
libvirt-0.3.3-7.el5

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL 5.2 dom0 on "system A"
2. Install RHEL 5.2 w/ virt-manager on "system B"
3. Configure systems for "remote virt-manager over ssh" -- create and
   propagate ssh key, etc.
4. 'yum remove nc' on system A
5. Start virt-manager on system B and attempt to connect to system A.
  
Actual results:
Unable to open a connection to the libvirt management daemon.

Expected results:
libvirt RPM should require nc, preventing problem.

Additional info:
Comment 1 Daniel Veillard 2008-06-09 14:51:24 EDT
oh, right, I will look at this, sound right to me, we did this for the fedora
package but it is missing from RHEL-5 <grin/>

Daniel
Comment 2 RHEL Product and Program Management 2008-06-09 14:54:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Daniel Veillard 2008-07-09 06:24:00 EDT
libvirt-0.3.3-11.el5 has been built in dist-5E-qu-candidate, with the fix

Daniel
Comment 8 errata-xmlrpc 2009-01-20 16:22:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0142.html

Note You need to log in before you can comment on or make changes to this bug.