Bug 450599 - last update broken sound
last update broken sound
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 15:40 EDT by Volnei
Modified: 2008-06-26 14:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 14:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod (2.46 KB, text/plain)
2008-06-16 09:28 EDT, Volnei
no flags Details
lspci -vv (18.79 KB, text/plain)
2008-06-16 09:29 EDT, Volnei
no flags Details
dmesg (23.01 KB, text/plain)
2008-06-16 09:29 EDT, Volnei
no flags Details
scsconfig.log+scsrun.log (46.19 KB, application/octet-stream)
2008-06-16 09:30 EDT, Volnei
no flags Details

  None (edit)
Description Volnei 2008-06-09 15:40:23 EDT
Description of problem:

After this last upgrade, the sound don't works.

Jun 09 11:28:21 Updated: kernel-headers - 2.6.25.4-10.fc8.i386
Jun 09 11:28:35 Installed: kernel-devel - 2.6.25.4-10.fc8.i686
Jun 09 11:29:16 Updated: evolution - 2.12.3-5.fc8.i386
Jun 09 11:29:18 Updated: system-config-printer-libs - 0.7.74.13-1.fc8.i386
Jun 09 11:29:20 Updated: aspell - 12:0.60.5-4.fc8.i386
Jun 09 11:29:25 Updated: evolution-help - 2.12.3-5.fc8.i386
Jun 09 11:29:26 Updated: system-config-printer - 0.7.74.13-1.fc8.i386
Jun 09 11:29:44 Installed: kernel - 2.6.25.4-10.fc8.i68


Version-Release number of selected component (if applicable):
FEDORA 8

How reproducible:
Update the kernel

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lennart Poettering 2008-06-13 19:33:11 EDT
This bug report is not very useful. Please elaborate what exactly doesn't work.
What fails? Do you see any error messages? Or is it that everything plays fine
but you don't hear anything?

If it's the latter, have you played around with the alsa mixer in a terminal
(alsamixer -c0)?
Comment 2 Volnei 2008-06-16 09:28:49 EDT
Created attachment 309493 [details]
lsmod
Comment 3 Volnei 2008-06-16 09:29:25 EDT
Created attachment 309495 [details]
lspci -vv
Comment 4 Volnei 2008-06-16 09:29:48 EDT
Created attachment 309497 [details]
dmesg
Comment 5 Volnei 2008-06-16 09:30:25 EDT
Created attachment 309500 [details]
scsconfig.log+scsrun.log
Comment 6 Volnei 2008-06-16 09:32:11 EDT
More additional informations:

ck-list-sessions.txt
Session1:
        uid = '0'
        realname = 'root'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2008-06-16T13:17:17Z'

# file: dev/snd/controlC0
# owner: root
# group: root
user::rw-
group::rw-
other::---


If you need more informations please ask-me
Thanks
Comment 7 Lennart Poettering 2008-06-17 13:33:38 EDT
Please elaborate what exactly doesn't work.
What fails? Do you see any error messages? Or is it that everything plays fine
but you don't hear anything?

If it's the latter, have you played around with the alsa mixer in a terminal
(alsamixer -c0)?

Also note that system-config-soundcard is obsolete and breaks sound setups.
Don't use it. It has been removed from Fedora.
Comment 8 Stephen Rowles 2008-06-19 10:02:32 EDT
There is no sound output from fedora after the latest round of updates. This
appears to be related to the kernel change to 2.6.25.4-10.fc8.

My machine just installed the latest round of automatic updates and I get no
sound output when playing (pulse or alsa).

Rebooting and going back to the previous kernel 2.6.24.7-92 solves this.

No errors are reported in dmesg or /var/log/messages. Sound playback appears to
work but there is no actual sound output :)

This is with the intel HDA sound module.

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller
(rev 02)
        Subsystem: Dell Optiplex 755
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fed04000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

Comment 9 Volnei 2008-06-24 08:46:19 EDT
After update to kernel 2.6.25.6-27 the sound come back to work, but very low. 
I increase the sound it stayed very low yet.
Comment 10 Lennart Poettering 2008-06-26 14:32:50 EDT
Please play around with "alsamixer -c0". Most likely your mixer is not
initialized properly and that is all.

Note You need to log in before you can comment on or make changes to this bug.