Bug 450639 - RHEL5.2 guest CDROM test failed of cannot get files from RHEL5.2 host
RHEL5.2 guest CDROM test failed of cannot get files from RHEL5.2 host
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity high
: ---
: ---
Assigned To: YangKun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 23:07 EDT by Spencer Tsai
Modified: 2008-08-03 22:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-03 22:11:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5.2 x86_64 guest system configuration files (572.73 KB, application/octet-stream)
2008-06-10 00:07 EDT, Spencer Tsai
no flags Details
RHEL5.2 x86_64 guest HTS-5.2-13, CDROM test result (636.82 KB, application/octet-stream)
2008-06-10 00:09 EDT, Spencer Tsai
no flags Details

  None (edit)
Description Spencer Tsai 2008-06-09 23:07:29 EDT
Description of problem:
RHEL5.2 guest CDROM test failed of cannot get files from RHEL5.2 host

Version-Release number of selected component (if applicable):
HTS-5.2-13

How reproducible:
Always reproducible

Steps to Reproduce:
1. Put RHEL5.2 x86_64 Install DVD-R to DVD-ROM /dev/scd0 
   (TSSTcorp, TS-633A, Sata Slim DVD ROM, Firmware UO01)
2. Setup guest CDROM connects to RHEL5.2 host DVD-ROM /dev/scd0
3. Boot RHEL5.2 x86_64 guest,
   Click CD-ROM icon in guest Desktop, but guest system shows CD/DVD Creator,
   No File Browser.
4. Shutdown guest, change CDROM connects to /var/lib/xen/iso/RHEL5.2_64_DVD.iso
5. Boot guest, but still shows CD/DVD creator, no File browser shows.

Actual results:
1. Since guest cannot open CDROM files, 
   HTS-5.2-13 CDROM test in RHEL5.2 guest always failed.

Expected results:

Additional info:
1. Has been reported a bug of RHEL5.2 virt-manager in bug number 450635.
Comment 1 Spencer Tsai 2008-06-10 00:07:10 EDT
Created attachment 308766 [details]
RHEL5.2 x86_64 guest system configuration files
Comment 2 Spencer Tsai 2008-06-10 00:09:02 EDT
Created attachment 308767 [details]
RHEL5.2 x86_64 guest HTS-5.2-13, CDROM test result
Comment 3 YangKun 2008-06-12 05:29:13 EDT
Hi,

Why run CDROM test in the FV guest ? This test should only be run in dom0.

Thanks
-YK
Comment 4 Spencer Tsai 2008-06-12 06:10:52 EDT
Dear YK,
I wondered too.
"CDROM" test item is generated automatically by command "hts plan".
After "hts plan" command, use "hts print --report summary" to list test items,
System shows "CDROM" test item under RHEL5.2 FV guest.

Before hts-5.1-18, FV guest test items never shows "CDROM".
This is first time I saw "CDROM" test item in hts-5.2-13.

I think this is hts-5.2-13 tool issue.
By the way, there's also a test item related bug 447783.
(447783 cpuscaling test never gets planned.)
Users need to add "cpuscaling" manually in hts-5.2-13.

Best Regards,

Spencer
Comment 5 YangKun 2008-06-12 21:17:58 EDT
Hi Spencer,

I think the change is in OS. RHEL5.2 brings a lot of improvements in
virtualization(including cdrom virtualization). But for hardware certification,
the CDROM test is not required in FV guests. You can simply disable this test in
the FV guest if it's added into the test plan:
    # hts plan --test cdrom --disable

As for bug#447783, it's been fixed in hts-5.2-14 

Can we close this bug now ?

Thanks
-YK
Comment 6 Spencer Tsai 2008-06-12 22:20:17 EDT
Hi YK,
Can you help to make sure that hts-5.2-14 has been released yet or not?
I cannot found out hts-5.2-14 under ftp://partners.redhat.com or RHN.
FTP newest hts is 5.2-13 and RHN version is only hts-5.1-18.

Maybe it's better to close this bug after hts-5.2-14 has been released.
Do you agree?

Best Regards,

Spencer
Comment 7 YangKun 2008-06-12 22:35:54 EDT
Hi Spencer,

hts-5.2-14 was kept as an internal testing release. We'll update the test suite
 soon on the partner ftp site(should be hts-5.2-16 or newer versions).

the cpuscaling issue can be tracked in bug#447783 .

I think your original concern of this bug is fixed, right ? Can we close this bug ?

Thanks
-YK
Comment 8 Spencer Tsai 2008-06-12 23:13:36 EDT
Hi YK,
If you are sure this hts plan bug has been fixed up in R14 or newer version,
please close it.

I will verify it after I got newer hts.
Thank you.

Spencer
Comment 9 YangKun 2008-06-13 02:03:56 EDT
Hi Spencer,

I'm confused, this bug has no business with the "cpuscaling" test planning issue
, right ?

The CDROM test been planned in FV guest is a correct behaviour in RHEL5.2 , you
just don't need to run it in FV.

-YK
Comment 10 Spencer Tsai 2008-06-30 04:12:26 EDT
Hi YK,
Under HTS-5.2-16, after runs "hts plan" in FV guest, hts test plan still has
"CDROM" test item.
Refer to your earlier reply, "CDROM" test item should be removed from FV guest
after HTS R14. But actually, HTS R16 still did not remove it from FV guest.
Comment 11 YangKun 2008-06-30 04:38:57 EDT
Hi Spencer,

The CDROM test been planned in FV guest is a CORRECT behaviour in RHEL5.2 , you
just don't need to run it in FV.

You can simply disable this test in the FV guest if it's added into the test plan:
    # hts plan --test cdrom --disable

-YK

Comment 12 YangKun 2008-08-03 22:11:41 EDT
closing this bug now since there's no update for more than a month.

Please re-open if necessary.

-YK

Note You need to log in before you can comment on or make changes to this bug.