Bug 450647 - kdump/kexec changes
kdump/kexec changes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Realtime_Tuning_Guide (Show other bugs)
beta
All Linux
low Severity low
: 1.1
: ---
Assigned To: Lana Brindley
Jeff Needle
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 02:10 EDT by Lana Brindley
Modified: 2013-10-23 19:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 20:54:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lana Brindley 2008-06-10 02:10:56 EDT
From email from Luis, 6 June, 2008:

Lana,

IBM folks just sent us a note on their tests with kdump. Jeff Burke also
gave us a few drops of his knowldge about this issue. The summary is
something along the lines of:


For those willing to use kdump / kexec:

* we provide a script called rt-setup-kdump, that comes with newer rt-setup
  versions, which creates a basic rhel-rt (MRG) compliant kdump setup. It uses
  rhel5.1 or rhel5.2 kernel as the kdump kernel.

* the MRG realtime kernel is not suited to be used as the kdump kernel,
  hence the decision to use rhel5 kernels.

* some machines, namely IBM's LS21, may show the following warning messages
  when booting the kdump kernel:

	irq 9: nobody cared (try booting with the "irqpoll" option) handlers:
	[<ffffffff811660a0>] (acpi_irq+0x0/0x1b)
	turning off IO-APIC fast mode.
	...

  This is noted on BZ#448715. Some systems just show the messages and and
  keep on booting. Other systems may freeze after displaying the messages.
  A known workaround is to add "acpi=noirq" as a boot parameter to the kdump
  kernel. This parameter should be used only when the messages above have been seen,
  because it may cause boot problems on systems not affected by the original issue.


Luis
-- [ Luis Claudio R. Goncalves Red Hat - Realtime Team ] [ Fingerprint: 4FDD
B8C4 3C59 34BD 8BE9 2696 7203 D980 A448 C8F8 ]
Comment 1 Lana Brindley 2008-06-10 02:12:35 EDT
Changes to be completed for 1.1 docs.

LKB
Comment 2 Lana Brindley 2008-10-29 18:05:51 EDT
Due to be completed today and will be available for technical review tomorrow.

LKB
Comment 3 Lana Brindley 2008-10-30 01:02:41 EDT
Completed and will be available for review shortly.

LKB

Note You need to log in before you can comment on or make changes to this bug.