Bug 450683 - [RFE] add -n to parted (dry-run capability)
[RFE] add -n to parted (dry-run capability)
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On: 447770
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 08:47 EDT by Joel Andres Granados
Modified: 2009-12-17 11:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 09:00:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Andres Granados 2008-06-10 08:47:28 EDT
+++ This bug was initially created as a clone of Bug #447770 +++

Escalated to Bugzilla from IssueTracker

-- Additional comment from tao@redhat.com on 2008-05-21 14:12 EST --
:Pythagoras Watson wrote:
:>Assuming the above work, then the only nice (for just this sort of
:>situation), but not necessary, option would be something akin to
:>sfdisk's "-n" option which will "go through all the motions, but do
:>not actually write to disk".
:>  
:Can you give me an idea of why you want to use that? Is it sort of a 
:"perform all the error checking to see if things will work" kind of thing?
:>==Py
:>

Precisely.  Currently, the only way to know if a command is legal is
to try it.  Trying commands like "mklabel" is highly destructive.
There are a bunch of testing-type situations (like right now), where I
would like to know if the command is acceptable and meaningful to
parted, but don't have destroyable resources.

==Py


This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 181369

-- Additional comment from tao@redhat.com on 2008-05-21 14:12 EST --
Who is the customer?
Lawrence Livermore National Lab

What is the exact nature of the problem trying to be solved with this
request?

add -n to the parted command


What, if any, business requirements are satisfied by this request? (What
is the use case context?)

We are telling customers to use parted for their large disk partitioning
needs, yet, there are a lot of problems and missing functionality in the
program. In this case, there's no way to do a 'dry run' where you can
go through all the motions of partitioning a drive, but, not actually
write the changes to disk.

List the functional requirement(s) for performing the action(s) that are
not presently possible. Please focus on describing the problem related
requirements without projecting any specific solution.

In parted's current state, the only way to know if a command is legal is
to try it.  Trying commands like "mklabel" is highly destructive.  If
you mess that up, you could very easily hose yourself.

In LLNL's situation, there are a bunch of testing-type situations where
they'd like to know if the command is acceptable and meaningful to
parted, but they don't have the luxury of having destroyable resources in
which to test out the parted commands.


Each functional requirement must have clear acceptance criteria so Red Hat
understands what success looks like. If test cases can be provided this
would be even more ideal (bonus points for RHTS test cases).

An "-n" option (or equivalent) added to parted that will let users
perform dry runs of partitioning activities without destroying anything on
disk.

What is the desired release vehicle to satisfy these requirements? Major
release Minor release

A minor RHEL release would be nice, depending on how things go with
upstream.

What package(s) are affected by this RFE? (List "new" if new technology
is likely to be required)  parted.


Issue escalated to SEG - Feature Request by: kbaxley.
Category set to: Applications::Feature Request
Internal Status set to 'Waiting on SEG'

This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 181369

-- Additional comment from jgranado@redhat.com on 2008-06-10 08:45 EST --
this is a feature that is better handled in fedora.  The amount of change to the
code and the test that have to go along with such a change are better handled
for RHEL6.
Comment 2 Joel Andres Granados 2009-06-12 04:55:28 EDT
James:
Currently trying to get parted-1.9.0  (has not been released yet, but will be very soon)  into f12.  This does not mean that it will have this feature.  We are addressing multiple issues in upstream and this feature is very low priority.  With that said, I do have this on my parted todo list, and if you would like to post a patch I would be happy to review for inclusion.
Comment 3 Hans de Goede 2009-12-16 09:00:38 EST
parted-2.1 is being released upstream and -n is not implemented. Also currently there are no plans upstream to add this feature, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.