Bug 450706 - txtest causes segmentation fault
txtest causes segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity high
: ---
: ---
Assigned To: Kim van der Riet
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 11:28 EDT by Gordon Sim
Modified: 2009-05-07 16:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 11:06:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-06-10 11:28:28 EDT
Observed on file-18 using:

./src/tests/txtest --queues 10 --messages-per-tx 2 --total-messages 2000
--tx-count 1000000 --size 64


#0  std::_Rb_tree<std::string, std::string, std::_Identity<std::string>,
std::less<std::string>, std::allocator<std::string> >::find (this=0x2aaab807f907,
    __k=@0x2aaab8018490)
    at
/usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../include/c++/4.1.2/bits/basic_string.h:591
#1  0x00002aaaab986437 in rhm::journal::wmgr::is_txn_synced (this=0xac26700,
    xid=@0x2aaab8018490)
    at
/usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../include/c++/4.1.2/bits/stl_set.h:444
#2  0x00002aaaab9636a0 in rhm::journal::jcntl::is_txn_synced (
    this=<value optimized out>, xid=@0x2aaab0203807) at jrnl/jcntl.cpp:391
#3  0x00002aaaab94c777 in rhm::bdbstore::TxnCtxt::sync (this=0x2aaab8018420)
    at TxnCtxt.h:119
#4  0x00002aaaab94caad in rhm::bdbstore::TxnCtxt::completeTXN (
    this=0x2aaab8018420, commit=true) at TxnCtxt.h:89
#5  0x00002aaaab935563 in rhm::bdbstore::BdbMessageStore::commit (
    this=0xa894b30, ctxt=<value optimized out>) at TxnCtxt.h:143
#6  0x00002aaaaab9dfd8 in qpid::broker::MessageStoreModule::commit ()
   from /home/gordon/qpid/cpp/src/.libs/libqpidbroker.so.0
#7  0x00002aaaaabd8743 in qpid::broker::TxBuffer::commitLocal ()
   from /home/gordon/qpid/cpp/src/.libs/libqpidbroker.so.0
#8  0x00002aaaaabb03a0 in qpid::broker::SemanticState::commit ()
   from /home/gordon/qpid/cpp/src/.libs/libqpidbroker.so.0

Suspect due to concurrent access to _pending_txn_set.
Comment 1 Gordon Sim 2008-06-10 15:00:27 EDT
Fixed by 2147.
Comment 2 Mike Bonnet 2008-06-19 23:53:29 EDT
qpidc-0.2.667603-1.el5, qpidc-perftest-0.2.667603-1.el5, qpidd-0.2.667603-1.el5, and rhm-0.2.2153-1.el5 have been pushed to the staging repo for testing

Note You need to log in before you can comment on or make changes to this bug.