Bug 450755 - tetex does not include lamstex fonts required by certain components of pb-diagram.
tetex does not include lamstex fonts required by certain components of pb-dia...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tetex (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 16:29 EDT by Ryan Curtin
Modified: 2013-07-02 19:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 14:11:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Curtin 2008-06-10 16:29:40 EDT
Description of problem:

tetex does not include lamstex fonts required by certain components of pb-diagram.

Version-Release number of selected component (if applicable):
tetex-33.2.el5_1.2

How reproducible:
Always, unless you dropped the fonts into /usr/share/texmf/fonts manually

Steps to Reproduce:
1.  Fire up some editor and create a LaTeX document with the line
"\usepackage{pb-diagram,lamsarrow,pb-lams}".
2.  Compile it.
3.  Watch it fail.
  
Actual results:
[LaTeX] test.tex => test.dvi (latex)
[LaTeX] finished with exit status 1
/usr/share/texmf/tex/latex/pb-diagram/lamsarrow.sty:89:Font \lamsfont@i=lams1
not loadable: Metric (TFM) file not found. \font
/usr/share/texmf/tex/latex/pb-diagram/lamsarrow.sty:90:Font \lamsfont@ii=lams2
not loadable: Metric (TFM) file not found. \font
/usr/share/texmf/tex/latex/pb-diagram/lamsarrow.sty:91:Font \lamsfont@iii=lams3
not loadable: Metric (TFM) file not found. \font
/usr/share/texmf/tex/latex/pb-diagram/lamsarrow.sty:92:Font \lamsfont@iv=lams4
not loadable: Metric (TFM) file not found. \font
/usr/share/texmf/tex/latex/pb-diagram/lamsarrow.sty:93:Font \lamsfont@v=lams5
not loadable: Metric (TFM) file not found.
[LaTeX] 5 errors, 0 warnings, 0 badboxes

Expected results:
[LaTeX] test.tex => test.dvi (latex)
[LaTeX] 0 errors, 0 warnings, 0 badboxes
[LaTeX] Done!

Additional info:

\usepackage{pb-diagram,lamsarrow,pb-lams} fails:

After some digging and reading, I found that this error is caused because the
lamsarrow package in pb-diagram depends on lamstex fonts, which are not included
in tetex at all.  While pb-diagram itself can run without lamstex (this error is
only encountered with the lamsarrow package), these files are required for the
lamsarrow package:

%{datadir}/texmf/fonts/tfm/lams1.tfm
%{datadir}/texmf/fonts/tfm/lams2.tfm
%{datadir}/texmf/fonts/tfm/lams3.tfm
%{datadir}/texmf/fonts/tfm/lams4.tfm
%{datadir}/texmf/fonts/tfm/lams5.tfm
%{datadir}/texmf/fonts/mf/lams1.mf
%{datadir}/texmf/fonts/mf/lams2.mf
%{datadir}/texmf/fonts/mf/lams3.mf
%{datadir}/texmf/fonts/mf/lams4.mf
%{datadir}/texmf/fonts/mf/lams5.mf

These files can all be found in CTAN:
http://www.ctan.org/tex-archive/macros/lamstex/

Can these files be included with the base tetex-fonts package, or should some
sort of tetex-lamstex package be made?  I will be creating RPMs for work use, so
the spec files used there may be helpful and I will post them if they are useful.
Comment 2 Jindrich Novy 2009-05-07 09:45:34 EDT
Fix to add lamstex fonts to teTeX is now added.
Comment 6 errata-xmlrpc 2009-06-22 14:11:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1118.html

Note You need to log in before you can comment on or make changes to this bug.