This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450781 - Can not add/rm software after installing live CD to disk
Can not add/rm software after installing live CD to disk
Status: CLOSED DUPLICATE of bug 453217
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 18:36 EDT by Jim Avera
Modified: 2008-07-04 05:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-04 05:52:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of the error (11.16 KB, image/png)
2008-06-10 18:36 EDT, Jim Avera
no flags Details

  None (edit)
Description Jim Avera 2008-06-10 18:36:58 EDT
The fc9 live cd boots and the desktop has an icon "install to hard drive", 
which invokes a process which copies data from the live CD to hd partitions.

After doing that, System->Add/Remove Software results in a dialog with
a list of package sets ("Gnome desktop", "KDE desktop", etc.).  Clicking on
any of the package sets first says "downloading file lists" in the status bar,
but then an error dialog pops up saying:

    The group was not found
    comps categories could not be loaded

Then the program is stuck forever with "Querying" in the status bar
and the status indicator running back and forth, but nothing further happens.

Internet connectivity is not the problem (I am typing this on the same
system which can not install new software).   I am behind a NAT firewall,
but fc7 had no trouble installing/updating.   

Question: Is add/remove software supposed to work on systems installed
form the live CD, or must the regular install DVD be used for a fully-
functional system?

My guess is that install-from-live-CD omits something critical needed by
the application started by System->Administration->Add/Remove software.

I'm marking this bug 'urgent' because the live CD is supposed to be the easy
way to try out Fedora and install it on hard disk if you like it.
But the result is a system which gives this unhelpful error when trying to
add packages not on the live CD.   If the problem can not be fixed then
the "install to hard drive" option should either be removed from the live cd or
made to warn the user that the resulting system does not support 'add/remove
software'.
Comment 1 Jim Avera 2008-06-10 18:36:58 EDT
Created attachment 308871 [details]
screen shot of the error
Comment 2 Jason Tibbitts 2008-06-11 01:49:38 EDT
Not sure why this was filed under Package Review; unfortunately the package
reviewers can't really help here.  This sounds like either a gnome-packagekit or
PackageKit issue; I'll reassign to gnome-packagekit, but it's quite possible
that this will need to be reassigned again.
Comment 3 Robin Norwood 2008-06-11 09:55:06 EDT
I've testing installs from the livecd - they should work.

Does running yum from the commandline as root work (when packagekit is not running)?

Comment 4 Jim Avera 2008-06-13 15:40:28 EDT
I downloaded the regular (non-live) DVD image and did a normal
install, and got the same problem!

The problem was fixed by running
  yum grouplist
in a terminal window as root.

So, the bug seems to be that the install process does not
do something which "yum grouplist" does (whatever that is).
Comment 5 Jim Avera 2008-06-13 15:50:03 EDT
(continued...) I did not try using yum directly for installing software,
so it is not certain that "yum grouplist" fixed the problem or just that
running yum directly for any purpose fixed the problem.

One more thing: My install created new / and /boot partitions
on a second drive(/dev/sdb), and re-used an existing /home on /dev/sda
(without re-formatting).   There is an fc7 system on the other partitions
of /dev/sda, but they should not be accessed by the fc9 installation
since they are not mounted for any purpose.   Anyway, it is conceivable that
the install problem is somehow related to the system partitions being on the
second drive (though that would be very surprising).

Comment 6 Richard Hughes 2008-07-04 05:52:26 EDT

*** This bug has been marked as a duplicate of 453217 ***

Note You need to log in before you can comment on or make changes to this bug.