Bug 450788 - (xorg-2.6.25.4-10) Xorg server crashes on kernel-2.6.25.4-10.fc8 / Kernel Oops!
Xorg server crashes on kernel-2.6.25.4-10.fc8 / Kernel Oops!
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 20:42 EDT by Joshua Covington
Modified: 2008-06-11 16:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 16:21:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel stack from the oops (2.38 KB, text/plain)
2008-06-10 20:42 EDT, Joshua Covington
no flags Details
Xorg.0.log (41.04 KB, text/plain)
2008-06-10 20:44 EDT, Joshua Covington
no flags Details
xorg.conf (1.05 KB, text/plain)
2008-06-10 20:44 EDT, Joshua Covington
no flags Details

  None (edit)
Description Joshua Covington 2008-06-10 20:42:52 EDT
Description of problem:
After upgrading to kernel-2.6.25.4-10.fc8 my xorg-server crashes. i have no
problems with the older kernel-2.6.24.7-92.fc8.

when starting the kernel with "quite rhgb" the rhgb cannot start, but at the end
i see the gdm-greeter. when starting with "debug" it seems to work better.
after loging in and out, I got the message "gdm is disabled, untill xorg is
fixed.............."
It seems there are connection between the xorg and the fglrx driver. I heard
there are some problems with the fglrx not supporting the 2.6.25 kernel.


Version-Release number of selected component (if applicable):
kernel-2.6.24.7-92.fc8
kernel-2.6.25.4-10.fc8

gdm-2.20.5-1.fc8
here are all rpms starting with xorg*
xorg-x11-utils-7.3-1.fc8
xorg-x11-fonts-misc-7.2-3.fc8
xorg-x11-drv-evdev-1.1.2-5.fc8
xorg-x11-drv-hyperpen-1.1.0-5.fc8
xorg-x11-drv-palmax-1.1.0-4.fc8
xorg-x11-drv-fbdev-0.3.1-4.fc8
xorg-x11-drv-avivo-0.0.1-6.fc8
xorg-x11-drv-ur98-1.1.0-4.fc8
xorg-x11-drv-via-0.2.2-4.fc8
xorg-x11-drv-cyrix-1.1.0-5.fc8
xorg-x11-server-Xorg-1.3.0.0-44.fc8
xorg-x11-drv-ati-6.8.0-4.fc8
xorg-x11-drv-void-1.1.1-6.fc8
xorg-x11-fonts-Type1-7.2-3.fc8
xorg-x11-drv-mouse-1.2.3-1.fc8
xorg-x11-drv-i810-2.1.1-7.fc8
xorg-x11-drv-trident-1.2.3-6.fc8
xorg-x11-drv-calcomp-1.1.0-4.fc8
xorg-x11-drv-tdfx-1.3.0-6.fc8
xorg-x11-drv-apm-1.1.1-7.fc8
xorg-x11-drv-glint-1.1.1-7.fc8
xorg-x11-server-utils-7.3-2.fc8
xorg-x11-drv-amd-2.7.7.7-2.fc8
xorg-x11-twm-1.0.3-1.fc8
xorg-x11-fonts-ISO8859-1-100dpi-7.2-3.fc8
xorg-x11-drv-vesa-1.3.0-10.fc8
xorg-x11-drv-aiptek-1.0.1-5.fc8
xorg-x11-drv-s3virge-1.9.1-5.fc8
xorg-x11-drv-acecad-1.1.0-5.fc8
xorg-x11-drv-sisusb-0.8.1-9.fc8
xorg-x11-drv-digitaledge-1.1.0-4.fc8
xorg-x11-drv-fglrx-libs-8.493-1.8.05.lvn8
xorg-x11-xauth-1.0.2-3.fc8
xorg-x11-apps-7.3-1.fc8
xorg-x11-xinit-1.0.7-2.fc8
xorg-x11-fonts-100dpi-7.2-3.fc8
xorg-x11-drv-keyboard-1.2.2-2.fc8
xorg-x11-drv-elographics-1.1.0-4.fc8
xorg-x11-drv-ark-0.6.0-6.fc8
xorg-x11-drv-tek4957-1.1.0-4.fc8
xorg-x11-drv-i128-1.2.1-1.fc8
xorg-x11-drv-fpit-1.1.0-4.fc8
xorg-x11-drv-microtouch-1.1.0-2.fc7
xorg-x11-drv-voodoo-1.1.1-1.fc8
xorg-x11-drv-citron-2.2.0-2.fc7
xorg-x11-drv-cirrus-1.1.0-5.fc8
xorg-x11-drv-siliconmotion-1.5.1-3.fc8
xorg-x11-drv-dynapro-1.1.0-3.fc7
xorg-x11-drv-v4l-0.1.1-8.fc8
xorg-x11-drv-mutouch-1.1.0-5.fc8
xorg-x11-drv-nv-2.1.6-1.fc8
xorg-x11-fonts-truetype-7.2-3.fc8
xorg-x11-drv-neomagic-1.1.1-4.fc8
xorg-x11-drv-dmc-1.1.0-3.fc7
xorg-x11-drv-ast-0.81.0-6.fc8
xorg-x11-drv-chips-1.1.1-5.fc8
xorg-x11-drv-jamstudio-1.1.0-4.fc8
xorg-x11-drv-spaceorb-1.1.0-4.fc8
xorg-x11-drv-i740-1.1.0-5.fc8
xorg-x11-drv-summa-1.1.0-4.fc8
xorg-x11-xkb-utils-7.2-3.fc8
xorg-x11-font-utils-7.2-2.fc8
xorg-x11-xdm-1.1.6-2.fc8
xorg-x11-drv-magictouch-1.0.0.5-5.fc8
xorg-x11-drv-vmware-10.15.2-1.fc8
xorg-x11-drv-magellan-1.1.0-4.fc8
xorg-x11-drv-savage-2.1.3-1.fc8
xorg-x11-drv-mga-1.4.6.1-6.fc8
xorg-x11-drv-sis-0.9.3-4.fc8
xorg-x11-drv-fglrx-8.493-1.8.05.lvn8
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-drv-penmount-1.1.0-3.fc7
xorg-x11-drv-rendition-4.1.3-5.fc8
xorg-x11-drv-nsc-2.8.1-4.fc8
xorg-x11-drv-tseng-1.1.0-7.fc8
xorg-x11-drv-s3-0.5.0-5.fc8
xorg-x11-drv-vmmouse-12.4.3-1.fc8
xorg-x11-drv-dummy-0.2.0-5.fc8
xorg-x11-drivers-7.2-9.fc8
xorg-x11-drv-nouveau-2.1.6-1.fc8
xorg-x11-proto-devel-7.3-3.fc8

kmod-fglrx-2.6.24.7-92.fc8-8.493-1.8.05.lvn8
xorg-x11-drv-fglrx-libs-8.493-1.8.05.lvn8
kmod-fglrx-2.6.25.4-10.fc8-8.493-2.8.05.lvn8
xorg-x11-drv-fglrx-8.493-1.8.05.lvn8
kmod-fglrx-8.493-2.8.05.lvn8




How reproducible:
make the update


Steps to Reproduce:
1.
2.
3.
  
Actual results:
n/a


Expected results:
it should work


Additional info:
the ati driver works in both case with problems.
Comment 1 Joshua Covington 2008-06-10 20:42:52 EDT
Created attachment 308879 [details]
kernel stack from the oops
Comment 2 Joshua Covington 2008-06-10 20:44:00 EDT
Created attachment 308880 [details]
Xorg.0.log
Comment 3 Joshua Covington 2008-06-10 20:44:35 EDT
Created attachment 308881 [details]
xorg.conf
Comment 4 Joshua Covington 2008-06-11 15:10:21 EDT
I searched through some forums and added the following to the xorg.conf

Section "DRI"
Mode 0666
EndSection 

Now I can start the kernel with "quiet rhgb". however I got 3 kernel panics
(seen in the dmesg). i filtered dmesg with fglrx and this is what came out:

fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg,
GERMANY' taints kernel.
Symbol init_mm is marked as UNUSED, however this module is using it.
This symbol will go away in the future.
Please evalute if this is the right api to use, and if it really is, submit a
report the linux kernel mailinglist together with submitting your code for
inclusion.
[fglrx] Adapter chains initialized successfully!
[fglrx] CF object manager initialized successfully!
[fglrx]   vendor: 1002 device: 5975 count: 1
[fglrx] Maximum main memory to use for locked dma buffers: 1776 MBytes.
[fglrx] ASYNCIO init succeed!
[fglrx] PAT is enabled successfully!
[fglrx] module loaded - fglrx 8.49.7 [May 12 2008] with 1 minors
[fglrx] GART Table is not in FRAME_BUFFER range
.................................................
 [<f8b135b0>] ? firegl_version+0x0/0x1b0 [fglrx]
 [<f8b13477>] ? firegl_ioctl+0xe7/0x220 [fglrx]
 [<f8b08c66>] ? ip_firegl_ioctl+0xe/0x10 [fglrx]
[fglrx:firegl_release] *ERROR* device busy: 1 0
[fglrx] release failed with code -EBUSY
.................................................
 [<f8b135b0>] ? firegl_version+0x0/0x1b0 [fglrx]
 [<f8b13477>] ? firegl_ioctl+0xe7/0x220 [fglrx]
 [<f8b08c66>] ? ip_firegl_ioctl+0xe/0x10 [fglrx]
[fglrx:firegl_release] *ERROR* device busy: 1 0
[fglrx] release failed with code -EBUSY
[fglrx] GART Table is not in FRAME_BUFFER range
[fglrx] Reserved FB block: Shared offset:0, size:0
[fglrx] Reserved FB block: Unshared offset:7ff5000, size:0
[fglrx] interrupt source 20008000 successfully enabled
[fglrx] enable ID = 0x00000004
[fglrx] Receive enable interrupt message with irqEnableMask: 20008000

It is a problem of the lates ati driver (8.497) and the 2.6.25 kernel. There are
no obvious problems with the modified xorg.conf but I don't like the  kernel
panics in the dmesg. Can someone put back init_mm symbol or correct this in the
fedora kernel?
Comment 5 Matěj Cepl 2008-06-11 16:21:23 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

Note You need to log in before you can comment on or make changes to this bug.