Bug 450797 - F8 Regression: number pad no longer works
F8 Regression: number pad no longer works
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 21:58 EDT by Jeff Garzik
Modified: 2018-04-11 07:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 16:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb -v output (11.58 KB, text/plain)
2008-06-10 21:58 EDT, Jeff Garzik
no flags Details
lspci -v output (7.88 KB, text/plain)
2008-06-10 21:59 EDT, Jeff Garzik
no flags Details
xorg.conf (1.04 KB, text/plain)
2008-06-10 22:00 EDT, Jeff Garzik
no flags Details
Xorg logs (19.44 KB, application/octet-stream)
2008-06-12 22:20 EDT, Jeff Garzik
no flags Details
Xorg.setup.log from the attachment 309157 tarball (875 bytes, text/plain)
2008-06-13 16:08 EDT, Matěj Cepl
no flags Details
Xorg.0.log from the attachment 309157 tarball (82.20 KB, text/plain)
2008-06-13 16:08 EDT, Matěj Cepl
no flags Details
Xorg.0.log.old from the attachment 309157 tarball (82.52 KB, text/plain)
2008-06-13 16:08 EDT, Matěj Cepl
no flags Details
Xorg.1.log from the attachment 309157 tarball (15.54 KB, text/plain)
2008-06-13 16:08 EDT, Matěj Cepl
no flags Details
Xorg.2.log from the attachment 309157 tarball (1.84 KB, text/plain)
2008-06-13 16:08 EDT, Matěj Cepl
no flags Details
Xorg.2.log.old from the attachment 309157 tarball (15.54 KB, text/plain)
2008-06-13 16:08 EDT, Matěj Cepl
no flags Details
Xorg.3.log from the attachment 309157 tarball (15.54 KB, text/plain)
2008-06-13 16:08 EDT, Matěj Cepl
no flags Details
Xorg.4.log from the attachment 309157 tarball (15.54 KB, text/plain)
2008-06-13 16:09 EDT, Matěj Cepl
no flags Details
Xorg.5.log from the attachment 309157 tarball (15.54 KB, text/plain)
2008-06-13 16:09 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Jeff Garzik 2008-06-10 21:58:49 EDT
Description of problem:
Under Fedora 8/x86-64, the number pad for my USB keyboard works as expected,
when numlock is turned on.

Under Fedora 9/x86-64, the number pad causes the mouse cursor to move around on
the screen in a predictable manner:  (7 == move upper left diagonal, 6 == move
right, 2 == move down, etc.)

Numlock and number pad work as expected when in console mode, thus only X11 is
affected.

lsusb output:
Bus 002 Device 004: ID 045e:000b Microsoft Corp. Natural Keyboard Elite
Bus 002 Device 002: ID 045e:0047 Microsoft Corp. IntelliMouse Explorer 3.0


Version-Release number of selected component (if applicable):
xorg-x11-drv-keyboard-1.3.0-3.fc9.x86_64

lspci and lsusb attached.

How reproducible:
always

Steps to Reproduce:
1. Install Fedora 8
2. turn on numlock
3. press number keys on numpad
  
Actual results:
Mouse cursor moves.

Expected results:
Numbers appear on screen (when in terminal or editor etc).

Additional info:
Comment 1 Jeff Garzik 2008-06-10 21:58:49 EDT
Created attachment 308885 [details]
lsusb -v output
Comment 2 Jeff Garzik 2008-06-10 21:59:18 EDT
Created attachment 308886 [details]
lspci -v output
Comment 3 Jeff Garzik 2008-06-10 22:00:22 EDT
Created attachment 308887 [details]
xorg.conf
Comment 4 Matěj Cepl 2008-06-11 06:43:25 EDT
Could I ask for /var/log/Xorg.*.log as well, please?
Comment 5 Jeff Garzik 2008-06-12 22:20:33 EDT
Created attachment 309157 [details]
Xorg logs
Comment 6 Jeff Garzik 2008-06-12 22:23:42 EDT
Just attached a tarball with all my Xorg logs.  Some may be from Fedora 8, I did
not check.

NOTE/CORRECTION:  In "Steps to Reproduce", #1 should read

     Install Fedora 9

not

     Install Fedora 8

Comment 7 Matěj Cepl 2008-06-13 16:08:02 EDT
Created attachment 309280 [details]
Xorg.setup.log from the attachment 309157 [details] tarball
Comment 8 Matěj Cepl 2008-06-13 16:08:12 EDT
Created attachment 309282 [details]
Xorg.0.log from the attachment 309157 [details] tarball
Comment 9 Matěj Cepl 2008-06-13 16:08:22 EDT
Created attachment 309283 [details]
Xorg.0.log.old from the attachment 309157 [details] tarball
Comment 10 Matěj Cepl 2008-06-13 16:08:30 EDT
Created attachment 309284 [details]
Xorg.1.log from the attachment 309157 [details] tarball
Comment 11 Matěj Cepl 2008-06-13 16:08:37 EDT
Created attachment 309285 [details]
Xorg.2.log from the attachment 309157 [details] tarball
Comment 12 Matěj Cepl 2008-06-13 16:08:45 EDT
Created attachment 309286 [details]
Xorg.2.log.old from the attachment 309157 [details] tarball
Comment 13 Matěj Cepl 2008-06-13 16:08:53 EDT
Created attachment 309287 [details]
Xorg.3.log from the attachment 309157 [details] tarball
Comment 14 Matěj Cepl 2008-06-13 16:09:00 EDT
Created attachment 309288 [details]
Xorg.4.log from the attachment 309157 [details] tarball
Comment 15 Matěj Cepl 2008-06-13 16:09:08 EDT
Created attachment 309289 [details]
Xorg.5.log from the attachment 309157 [details] tarball
Comment 16 James Ralston 2008-06-13 17:53:01 EDT
I'm seeing this as well.  I have a "Saitek PLC" USB keyboard.

(Jeff already provided quite a bit of information, so I'll refrain from
attaching all of my information unless someone specifically says they want it...)
Comment 17 Jeff Garzik 2008-06-18 02:37:41 EDT
NOTE:  Ctrl-Shift-Numlock restores proper numpad behavior (Dave Airlie's tip)
Comment 18 Martin Nagy 2008-06-23 16:35:27 EDT
I'm seeing this as well.
Comment 19 Peter Hutterer 2008-07-21 02:12:05 EDT
I need a few additional logs to track this down - I can't reproduce it on server
1.5 branch tip, nor on F9, nor on git master.

please post:
- the output of xev when hitting the num key (that activates mouse keys) before
and after it has been deactivated with Ctrl+Shift+NumLock.
- the server-0.xkb file generated when running xkbcomp :0
- the output of xkbset q (google for your favourite mirror, I got mine from the
debian repository)
Comment 20 Martin Nagy 2008-08-14 03:36:01 EDT
(In reply to comment #19)
> I need a few additional logs to track this down - I can't reproduce it on server
> 1.5 branch tip, nor on F9, nor on git master.
> 
> please post:
> - the output of xev when hitting the num key (that activates mouse keys) before
> and after it has been deactivated with Ctrl+Shift+NumLock.

Jeff, after pressing Ctrl+Shift+NumLock as you suggested, the num pad starts working again. I didn't even know about this shortcut. Perhaps there was a bad default setting? Or I've just pressed this accidentally, but I'm not sure about that..
Comment 21 James Ralston 2008-08-14 11:07:39 EDT
I can no longer reproduce this bug, either. I suspect it was already (accidentally, perhaps?) squashed...
Comment 22 Matěj Cepl 2008-09-09 16:10:29 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.