Bug 450803 - Update pidgin from 2.4.1 to 2.4.2 on F8.
Update pidgin from 2.4.1 to 2.4.2 on F8.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 00:15 EDT by Caius Chance
Modified: 2008-06-11 21:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 07:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2008-06-11 00:15:38 EDT
Description of problem:
Pidgin is still at version 2.4.1 on Fedora 8, which results no msnp14 protocol
supported.

Version-Release number of selected component (if applicable):
pidgin-2.4.1

How reproducible:
Always.

Steps to Reproduce:
1. Go to console.
2. Input `rpm -q pidgin`.
3. Check package version.
  
Actual results:
pidgin-2.4.1

Expected results:
pidgin-2.4.2

Additional info:
Comment 1 Stu Tomlinson 2008-06-11 07:52:33 EDT
It's available in updates-testing, and will be in stable updates soon :
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-4298

Note that MSNP14 is not enabled in the Fedora build, and almost certainly will
not be until we (upstream) determine it is ready enough to be enabled by default.
Comment 2 Caius Chance 2008-06-11 19:40:26 EDT
Thanks Stu, I just want a 2.4.2 and enable msnp14 by myself. 2.4.1 doesn't have
the --enable-msnp14 switch available, so I requested this.
Comment 3 Stu Tomlinson 2008-06-11 21:21:19 EDT
(In reply to comment #2)
> Thanks Stu, I just want a 2.4.2 and enable msnp14 by myself. 2.4.1 doesn't have
> the --enable-msnp14 switch available, so I requested this.

I'm not sure how you think Fedora's binary packages provide you with an easy way
to enable msnp14, but 2.4.2's source has had --enable-msnp14 since May 17th when
it was released. (in case it wasn't clear, this is an option to pass to
./configure when building from source).
Comment 4 Caius Chance 2008-06-11 21:34:48 EDT
Do you mean even if you upgrade it to 2.4.2, if it wasn't compiled with such
option, it still doesn't have --enable-msnp14 option available? If so, then
that's alright and I keep myself on emesene then. :)
Comment 5 Stu Tomlinson 2008-06-11 21:59:19 EDT
(In reply to comment #4)
> Do you mean even if you upgrade it to 2.4.2, if it wasn't compiled with such
> option, it still doesn't have --enable-msnp14 option available?

That's correct, --enable-msnp14 is a compile-time option for early adopters
willing to risk using known-buggy code to help it mature to the level where we
can enable it for everyone.

Note You need to log in before you can comment on or make changes to this bug.