Bug 450833 - gfs_debug build warning
gfs_debug build warning
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: GFS (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robert Peterson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 05:38 EDT by Steve Whitehouse
Modified: 2008-06-13 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 12:47:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (599 bytes, patch)
2008-06-12 12:16 EDT, Robert Peterson
no flags Details | Diff

  None (edit)
Description Steve Whitehouse 2008-06-11 05:38:07 EDT
From is64 build logs:

gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -DHELPER_PROGRAM -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_debug/../include
-I/usr/include -c -o readfile.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_debug/readfile.c
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_debug/readfile.c: In
function 'readfile':
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_debug/readfile.c:185:
warning: ignoring return value of 'write', declared with attribute
warn_unused_result
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -DHELPER_PROGRAM -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_debug/../include
-I/usr/include -c -o util.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_debug/util.c
gcc -o gfs_debug block_device.o basic.o main.o ondisk.o readfile.o util.o
Comment 1 Robert Peterson 2008-06-12 12:16:45 EDT
Created attachment 309091 [details]
Proposed patch

This is what I'll be pushing.
Comment 2 Robert Peterson 2008-06-12 12:39:35 EDT
This patch was tested on exxon-01 and a1 (ia64).  It was pushed to
master and STABLE2.
Comment 3 Fabio Massimo Di Nitto 2008-06-12 23:51:53 EDT
Looks good here too on all arches.
Comment 4 Robert Peterson 2008-06-13 12:47:47 EDT
Closing as UPSTREAM, since this is in the upstream cluster git repository.

Note You need to log in before you can comment on or make changes to this bug.