This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450837 - gfs_tool build warnings
gfs_tool build warnings
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: GFS (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robert Peterson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 05:46 EDT by Steve Whitehouse
Modified: 2008-06-13 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 12:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Whitehouse 2008-06-11 05:46:08 EDT
From the ia64 build logs:

gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -DHELPER_PROGRAM -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_quota/../include
-I/usr/include -c -o layout.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_quota/layout.c
gcc -o gfs_quota check.o main.o names.o ondisk.o layout.o 
make[2]: Leaving directory
`/usr/src/upstream/cluster/rhcluster/obj-ia64/gfs/gfs_quota'
make[2]: Entering directory
`/usr/src/upstream/cluster/rhcluster/obj-ia64/gfs/gfs_tool'
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/../include
-I/usr/include -c -o counters.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/counters.c
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/counters.c: In function
'print_counters':
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/counters.c:189:
warning: ignoring return value of 'write', declared with attribute
warn_unused_result
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/../include
-I/usr/include -c -o df.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/df.c
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/../include
-I/usr/include -c -o layout.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/layout.c
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/../include
-I/usr/include -c -o main.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/main.c
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/main.c: In function
'print_usage':
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/main.c:113: warning:
format not a string literal and no format arguments
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/../include
-I/usr/include -c -o misc.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/misc.c
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/misc.c: In function
'print_lockdump':
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/misc.c:161: warning:
ignoring return value of 'write', declared with attribute warn_unused_result
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/misc.c: In function
'reclaim_metadata':
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/misc.c:643: warning:
ignoring return value of 'fgets', declared with attribute warn_unused_result
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/../include
-I/usr/include -c -o ondisk.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/ondisk.c
gcc -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -Wall -Wformat=2 -MMD -O2 -g
-I/usr/src/upstream/cluster/rhcluster/cluster/make
-DDEFAULT_CONFIG_DIR=\"/etc/cluster\" -DDEFAULT_CONFIG_FILE=\"cluster.conf\"
-DLOGDIR=\"/var/log/cluster\" -DSYSLOGFACILITY=LOG_LOCAL4
-DRELEASE_VERSION=\"2.99.03\" -D_FILE_OFFSET_BITS=64
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs-kernel/src/gfs
-I/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/../include
-I/usr/include -c -o sb.o
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/sb.c
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/sb.c: In function 'do_sb':
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/sb.c:78: warning:
pointer targets in passing argument 1 of 'fgets' differ in signedness
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/sb.c:89: warning:
pointer targets in passing argument 2 of 'gfs_sb_in' differ in signedness
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/sb.c:142: warning:
pointer targets in passing argument 2 of 'gfs_sb_out' differ in signedness
/usr/src/upstream/cluster/rhcluster/cluster/gfs/gfs_tool/sb.c:78: warning:
ignoring return value of 'fgets', declared with attribute warn_unused_result
Comment 1 Fabio Massimo Di Nitto 2008-06-12 23:49:23 EDT
Looks good now on all arches.

Fabio
Comment 2 Robert Peterson 2008-06-13 12:49:06 EDT
Closing as UPSTREAM, since this is in the upstream cluster git repository.

Note You need to log in before you can comment on or make changes to this bug.