Bug 45106 - freshly broken 'eject'
freshly broken 'eject'
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: eject (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-19 23:41 EDT by Michal Jaegermann
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-19 23:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-06-19 23:41:07 EDT
'eject-2.0.2-7' from Seawolf-gold on Alpha got broken.  Until and including
RC1 'eject' without other arguments was unmounting, if mounted, and
ejecting
CD.  This what happens right now:

Here is what 'mount' has to show
/dev/cdrom on /dev/cdrom type iso9660 (ro,nosuid,nodev)
and /dev/cdrom is a link to /dev/hdd

Now lets us see:

# eject
eject: unable to eject, last error: Invalid argument
# eject -v
eject: using default device `cdrom'
eject: device name is `cdrom'
eject: expanded name is `/dev/cdrom'
eject: `/dev/cdrom' is a link to `/dev/hdd'
eject: `/dev/hdd' is not mounted
eject: `/dev/hdd' is not a mount point
eject: `/dev/hdd' is a multipartition device
eject: trying to eject `/dev/hdd' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/hdd' using SCSI commands
eject: SCSI eject failed
eject: trying to eject `/dev/hdd' using floppy eject command
eject: floppy eject command failed
eject: trying to eject `/dev/hdd' using tape offline command
eject: tape offline command failed
eject: unable to eject, last error: Invalid argument

# eject -v /mnt/cdrom
eject: device name is `/mnt/cdrom'
eject: expanded name is `/mnt/cdrom'
eject: `/mnt/cdrom' is not mounted
eject: `/dev/cdrom' can be mounted at `/mnt/cdrom'
eject: `/dev/cdrom' is not a multipartition device
eject: trying to eject `/dev/cdrom' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/cdrom' using SCSI commands
eject: SCSI eject failed
eject: trying to eject `/dev/cdrom' using floppy eject command
eject: floppy eject command failed
eject: trying to eject `/dev/cdrom' using tape offline command
eject: tape offline command failed
eject: unable to eject, last error: Invalid argument

# eject -v /dev/hdd
eject: device name is `/dev/hdd'
eject: expanded name is `/dev/hdd'
eject: `/dev/hdd' is not mounted
eject: `/dev/hdd' is not a mount point
eject: `/dev/hdd' is a multipartition device
eject: trying to eject `/dev/hdd' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/hdd' using SCSI commands
eject: SCSI eject failed
eject: trying to eject `/dev/hdd' using floppy eject command
eject: floppy eject command failed
eject: trying to eject `/dev/hdd' using tape offline command
eject: tape offline command failed
eject: unable to eject, last error: Invalid argument

After CD is unmounted then 

# eject -v
eject: using default device `cdrom'
eject: device name is `cdrom'
eject: expanded name is `/dev/cdrom'
eject: `/dev/cdrom' is a link to `/dev/hdd'
eject: `/dev/hdd' is not mounted
eject: `/dev/hdd' is not a mount point
eject: `/dev/hdd' is a multipartition device
eject: trying to eject `/dev/hdd' using CD-ROM eject command
eject: CD-ROM eject command succeeded

This is a nasty regress.  After replacing in /etc/fstab /dev/cdrom with
an explicit /dev/hdd 'eject' starts works again like before and unmounts
and ejects mounted CDs.

  Michal
  michal@harddata.com
Comment 1 Ngo Than 2001-06-26 09:35:34 EDT
It's fixed in eject-2.0.9-2. You find it in rawhide
Comment 2 Michal Jaegermann 2001-06-27 00:06:45 EDT
This indeed seems to be the case.   Thanks!
Should "RESOLVED RAWHIDE" imply "CLOSED" or not?

Note You need to log in before you can comment on or make changes to this bug.