Bug 45107 - 'mount' coredumps
'mount' coredumps
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-19 23:55 EDT by Michal Jaegermann
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-27 00:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-06-19 23:55:18 EDT
After a typo mount-2.11e-1 does "Segmentation fault (core dumped)"
and indeed dumps a core.  Loading this core in gdb gives this:

Core was generated by `mount /dev/sda8 xtra/'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libc.so.6.1...done.
Loaded symbols for /lib/libc.so.6.1
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x200000e8060 in strncmp () from /lib/libc.so.6.1
(gdb) bt
#0  0x200000e8060 in strncmp () from /lib/libc.so.6.1
#1  0x12000ac5c in error ()
warning: Hit heuristic-fence-post without finding
warning: enclosing function for address 0x120003b48

Repeatable with a full reliability (It was supposed to be /dev/sdb8
which indeed exists on my machine).

   Michal
   michal@harddata.com
Comment 1 Phil Copeland 2001-06-24 13:55:36 EDT
[root@dhcpd141 alpha]# rpm -q mount
mount-2.11e-1
[root@dhcpd141 alpha]# mount /dev/sda1 xtra/
mount: mount point xtra/ does not exist
[root@dhcpd141 alpha]# mkdir xtra/
[root@dhcpd141 alpha]# mount /dev/sda1 xtra/
[root@dhcpd141 alpha]# 

Sorry, I can't recreate this on my equipment
Comment 2 Michal Jaegermann 2001-06-24 15:55:26 EDT
You are not paying attention to reports.  The point is not a missing mount
location but /dev/sda8 - which happen not to exist as opposed to /dev/sdb8.
Regardless of a typo a core from 'mount' is a BUG.
Comment 3 Bernhard Rosenkraenzer 2001-06-26 08:19:28 EDT
Fixed in 2.11f-2
Comment 4 Michal Jaegermann 2001-06-26 23:57:32 EDT
It does not seem to be the case, I am afraid.

# rpm -q mount
mount-2.11f-1
toaster:/mnt#
# mount /dev/sda8 xtra
Segmentation fault (core dumped)

Once again, an existence or non-existence of a mount point does
not matter.  What matters that on a disk /dev/sda I do not have
a partition sda8 (sda5 happens to be the highest one and this is
a BSD-type partitioning, not FAT).

# gdb /bin/mount core
GNU gdb Red Hat Linux 7.x (5.0rh-9)
.....
Core was generated by `mount /dev/sda8 xtra'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libc.so.6.1...done.
Loaded symbols for /lib/libc.so.6.1
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x200000e8060 in strncmp () from /lib/libc.so.6.1
(gdb) bt
#0  0x200000e8060 in strncmp () from /lib/libc.so.6.1
#1  0x12000ad50 in error ()

Could be that 'glibc' version is important here?  This is the one
after the last update:

# rpm -q glibc
glibc-2.2.3-11

Comment 5 Michal Jaegermann 2001-06-27 00:04:28 EDT
Another change in 'mount' behaviour.  Maybe a related one?
With a line "/dev/cdrom /mnt/cdrom ..." in /etc/fstab and /cdrom a link
to /mnt/cdrom a command 'mount /cdrom' used to work.  Not anymore and
an explicit 'mount /mnt/cdrom' is required.

Easy to work around.
Comment 6 Bernhard Rosenkraenzer 2001-06-27 06:06:12 EDT
Umm... nobody claimed this was fixed in 2.11f-1.
I closed this bug with the remark "fixed in 2.11f-2", so don't reopen it 
because it doesn't work in 2.11f-1. ;)

It is not glibc related, it was simply a missing check for a NULL pointer 
before using strchr().

The other change seems intentional (looking at the diff, code for following 
links was explicitly removed).
Comment 7 Michal Jaegermann 2001-06-27 12:24:51 EDT
> nobody claimed this was fixed in 2.11f-1

Sorry!  My fault.  I grabbed yesterday the latest version from "rawhide"
on ftp.beta.redhat.com, noticed that it it was "f" and did not pay attention
that a "-1" is not a "-2".  Got fooled by an assumption that
ftp.beta.redhat.com will be somewhat close to beeing up-to-date.

Note You need to log in before you can comment on or make changes to this bug.